IDS 9.4 Stuck at Fast Recovery
Posted in 2007
Anyone
I havea test instance (not being archived that regularly) that
suffered some disk corruption (crossed chunks with another instance
!!). It has bee running OK and Ihave been sorting issues with indexes
as they appear (the crossed chunks were on a dbspace containing mainly
detatched indexes). However there does appear to be a table in one of
these chunks. oncheck -cI showed an issue and I sucessfully dropped
theindexes but was unable to recreate them. The next time I bounced
the instance it refused to start getting stuck at the Fast Recovery
stage. I have tried with -p option to oninit but to no avail.
Although this is only a test instance I really need to preserve most
of the data if at all possible. I can recreate the odd table or two
where required, but not all 200 Gb!!
Any suggestions as to whether it is possible to force this engine into
life by skipping the Fast Recovery in some way?
IDS9.4 FC6 on AIX 5.3.
onstat -p
IBM Informix Dynamic Server Version 9.40.FC6 -- Fast Recovery --
Up 19:41:49 -- 3020880 Kbytes
Profile
dskreads pagreads bufreads %cached dskwrits pagwrits bufwrits %cached
0 0 0 0.00 0 0 0 0.00
isamtot open start read write rewrite delete commit rollbk
0 0 0 0 0 0 0 0 0
gp_read gp_write gp_rewrt gp_del gp_alloc gp_free gp_curs
0 0 0 0 0 0 0
ovlock ovuserthread ovbuff usercpu syscpu numckpts flushes
0 0 0 70734.67 19.47 0 0
bufwaits lokwaits lockreqs deadlks dltouts ckpwaits compress seqscans
0 0 0 0 0 0 0 0
ixda-RA idx-RA da-RA RA-pgsused lchwaits
0 0 0 0 52
Thanks
Keith