Advise needed
Posted in 2009
Topics: Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL
Hi All,
Our users are bouncing back to the main 4gl application window
while entering orders and due to this they are losing orders.
I can see that below errors on 4gl application logs but no errors on Informix
DB 7.13 running on Hp-UNIX 10.01.
Please guide me how to troubleshoot this and the best approach to resolve this
issue & where could be the problem on application side or a database side.
Errors on 4GL application logs
ISAM error: Lock Timeout Expired
Date: 11/06/2009 Time: 15:31:03Program error at "bl_peggr.4gl", line number 1043.
SQL statement error number -245.
Could not position within a file via an index.
SYSTEM error number -154.
ISAM error: Lock Timeout Expired
Date: 11/06/2009 Time: 15:41:33Program error at "bl_dtl.4gl", line number 99.
SQL statement error number -245.
Could not position within a file via an index.
SYSTEM error number -154.
ISAM error: Lock Timeout Expired
Date: 11/06/2009 Time: 15:52:27Program error at "bl_peggr.4gl", line number 1043.
SQL statement error number -245.
Could not position within a file via an index.
SYSTEM error number -154.
ISAM error: Lock Timeout Expired
Date: 11/09/2009 Time: 13:32:01Program error at "bl_peggr.4gl", line number 1043.
SQL statement error number -245.
Could not position within a file via an index.
SYSTEM error number -154.
ISAM error: Lock Timeout Expired
Date: 11/09/2009 Time: 13:34:50Program error at "bl_peggr.4gl", line number 1043.
SQL statement error number -245.
Could not position within a file via an index.
SYSTEM error number -154.
ISAM error: Lock Timeout Expired
......so on
continous same error
We are observng this error for the couple of days and now it start effecting
the users work. please help.
Regards
Deepak
DEEPAK JOSHI wrote:
> Hi All,
>
> Our users are bouncing back to the main 4gl application window
> while entering orders and due to this they are losing orders.
>
> I can see that below errors on 4gl application logs but no errors on Informix
> DB 7.13 running on Hp-UNIX 10.01.
>
> Please guide me how to troubleshoot this and the best approach to resolve
this
> issue & where could be the problem on application side or a database side.
>
> Errors on 4GL application logs
>
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:31:03> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:41:33> Program error at "bl_dtl.4gl", line number 99.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:52:27> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:32:01> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:34:50> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> .......so on>
> continous same error
>
> We are observng this error for the couple of days and now it start effecting
> the users work. please help.
>
> Regards
> Deepak
>
Deepak - the issue is that there's a client application that's holding a lock
on a resource and not releasing it, while another client application (the one
that throws the error) would like to use it and has given up waiting for it.
The causes could be many - from a client that has started a transaction,
locked a row, and just went away for lunch (rather long lunch, two days),
though hopefully you should see it becoming long at some stage, and rollback,
to your instance generally becoming slower (maybe you lack required indexes,
or table hold more data than developers have anticipated), and client
applications now release locks in a longer time frame that your developers
have coded.
Without seeing the application logic or the instance, I can't really tell you
more.
Note though that this is the kind of error that a half decent developer would
have trapped and handled inside the application, so by all means nag your
developer and have it fixed by him, if he is still around, that is.
As a side and personal note - you should start paying a bit more attention to
what people tell you around here: ODS 7.13 is out of support, HPUX 10.01 is
out of support, your 4gl is most likely out of support, and you really should
be looking to enroll into some informix courses....
--
Ciao,
Marco
______________________________________________________________________________
Marco Greco /UK /IBM Standard disclaimers apply!
Structured Query Scripting Language http://www.4glworks.com/sqsl.htm
4glworks http://www.4glworks.com
Informix on Linux http://www.4glworks.com/ifmxlinux.htm
Deepak,
I only have two suggestions of the top of my head and without much
thought.
First check the locks on the table and it's indexes at the time of the error
(if you can). Something like the following.
SELECT *
FROM sysmaster:syslocks
WHERE tabname = "table_name";
For the indexes if they are detached you can join with the sysindexes
table so you don't have to look at each one.
SELECT *
FROM sysmaster:syslocks
WHERE tabname = "table_name"i
OR tabname IN (SELECT idxname
FROM database:sysindexes si,
database.systables st
WHERE si.ttabid = st.tabid
AND st.tabname = "table_name");
Second run an "oncheck -cID database:table" on the table. (if it isn't
large I would do this first)
(Note: if the D fails due to the table being used it's ok I
sucepct it is a problem with an index)
I would expect there is someing wrong with a lock, but if there isn't I
would start watching for a new process if it just started happening which
maybe doing something different with the data.
Eric B. Rowell
On Mon, Nov 9, 2009 at 2:21 PM, DEEPAK JOSHI <djoshih@hotmail.com> wrote:
> Hi All,
>
> Our users are bouncing back to the main 4gl application window
> while entering orders and due to this they are losing orders.
>
> I can see that below errors on 4gl application logs but no errors on
> Informix
> DB 7.13 running on Hp-UNIX 10.01.
>
> Please guide me how to troubleshoot this and the best approach to resolve
> this
> issue & where could be the problem on application side or a database side.
>
> Errors on 4GL application logs
>
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:31:03> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:41:33> Program error at "bl_dtl.4gl", line number 99.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:52:27> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:32:01> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:34:50> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> .......so on>
> continous same error
>
> We are observng this error for the couple of days and now it start
> effecting
> the users work. please help.
>
> Regards
> Deepak
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Eric B. Rowell
--0016e6da7db88879890477f56720
Someone is holding a lock on a critical table and it's causing your other
users to timeout their attempts to acquire the same lock or to scan past it
in a table or index scan (SQL Error -245 indicates that it is actually an
index scan that is encountering the lock). There could be several causes
from someone having opened an interactive query in dbaccess under a
transaction who never closed the session, a poorly designed application that
acquired a lock that had to be released by the action of some user who may
have gone on vacation without exiting the application, etc.
One thing you can try is to shutdown the engine and restart it. That will
get all existing sessions out of the database server and release all locks.
I'm going to suggest that you get someone who is very experienced in
Informix to take a good long look at your entire system. Something is not
right with all of the contention issues you have posted here. Contact me
privately if your company wants that kind of help.
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Mon, Nov 9, 2009 at 2:21 PM, DEEPAK JOSHI <djoshih@hotmail.com> wrote:
> Hi All,
>
> Our users are bouncing back to the main 4gl application window
> while entering orders and due to this they are losing orders.
>
> I can see that below errors on 4gl application logs but no errors on
> Informix
> DB 7.13 running on Hp-UNIX 10.01.
>
> Please guide me how to troubleshoot this and the best approach to resolve
> this
> issue & where could be the problem on application side or a database side.
>
> Errors on 4GL application logs
>
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:31:03> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:41:33> Program error at "bl_dtl.4gl", line number 99.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/06/2009 Time: 15:52:27> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:32:01> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> Date: 11/09/2009 Time: 13:34:50> Program error at "bl_peggr.4gl", line number 1043.
> SQL statement error number -245.
> Could not position within a file via an index.
> SYSTEM error number -154.
> ISAM error: Lock Timeout Expired
> .......so on>
> continous same error
>
> We are observng this error for the couple of days and now it start
> effecting
> the users work. please help.
>
> Regards
> Deepak
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0023545bd494f075850477f5836c
> Hi All,
>
> Our users are bouncing back to the main 4gl application window
> while entering orders and due to this they are losing orders.
>
> I can see that below errors on 4gl application logs but no errors on
> Informix DB 7.13 running on Hp-UNIX 10.01.
>
> Please guide me how to troubleshoot this and the best approach to resolve
> this issue & where could be the problem on application side or a database
> side.
>
> Errors on 4GL application logs
>
> ISAM error: Lock Timeout Expired
Talk to the programmers!
Are you the chap that asked for a 4ge decompiler the other day? If so, does
that mean you have no source code and no programmers? Oy vey!
--Boundary-00=_rrK+KRoOxFZbzE8