Re: restore failing from nfs ontape file
Posted in 2008
This is purely from memory, but because of the way ontape
opens-reads-seek0-read on the 'tape' it fails on NFS with the seek0
Try setting the device to be STDIO
and do
cat /some/file/on/nfs | ontape -r
--
Clive
Floyd Wellershaus wrote:
> Hi,
> Trying to backup a large database to an nfs filesystem on aix . aix
> 5.3, ids 10.0fc5.
> ontape backup seems to work, although I get a slightly different
> message at the end.
>
> The problem is that when I go to restore the database on the target
> system, it starts to work, presents all the chunks, asks me if I want
> to backup logs etc..., and then after about 10 or 15 minutes fails with:
>
> *Physical restore failed - function write physical restore failed code
> -1 errno 0 *
>
>
> So back to the backup.
>
> Normally I get :
> =====================
> 100 percent done.
>
>
> Please label this tape as number 1 in the arc tape sequence.
> This tape contains the following logical logs:
>
> [some number]
>
> Program over.
> ===============
>
> However, with these backups I am getting:
>
> *=========================
> * ** **
>
> *100 percent done.***
>
> *Read/Write End Of Medium enabled: blocks = 474623 ***
>
> * ***
>
> *Please label this tape as number 1 in the arc tape sequence. ***
>
> *This tape contains the following logical logs:***
>
> * ***
>
> * 177925***
>
> * ***
>
> *Program over.
> ============================
>
> ***
>
> I have both TAPEBLK set to 2048 ( on the target and the source ),
> I have both TAPESIZE set to zero.
>
> Any advice ?
>
> Thanks,
> floyd
>
>
>
>
> --
> This message has been scanned for viruses and
> dangerous content by *OpenProtect* <http://www.openprotect.com/>, and is
> believed to be clean.
> ------------------------------------------------------------------------
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>