Stubborn database, refuses to be dropped.
Posted in 1996
We have a database created under:
Informix 6.0 japanese
Solaris 2.4 japanese
Since then we have upgraded Informix and solaris many a times.
Current configuration:
Informix 7.12
Solaris 2.5
* Notice that the environment is not japanese anymore.
Well, now I want to drop that database.
I have tried setting DBNLS to all possible values.
I cannot set LANG,LC_ALL or LC_COLLATE to ja as I do not have that
environment anymore.
I get the following error when I try to connect or drop the database:
7203: DBNLS is not set or LC_COLLATE must be 'ja'.
117: ISAM error: bad custom collating sequence
I tricked the OS into allowing me to set LANG to ja by copying
/usr/lib/locale/C to /usr/lib/locale/ja
Now when I try to connect to the database I get
7204 LANG or LC_COLLATE environment variable is invalid.
I called Informix support, they offered three solutions:
Allow them to dial in and drop it.
dbexport every database, oninit -i and dbimport
use onarchive to do dbspace level restoral after saving all
db's in the offending dbspace that contains the database
that refuses to go away.
I find all three solutions too complicated. This is not that difficult.
Any help appreciated. JL listening?
--
--
Burzin N. Engineer |Tel. (310) 524 1800 | email: burzin@twinsun.com
Twin Sun Inc. |Fax. (310) 524 1818 | MIME OkaY!