Re: Is Informix 7.24.UC5-1 free of Feb 29, 2000 bug (B60150)
Posted in 1998
Hello,
I've received confirmation that the version information posted earlier this
month has been overtaken by events, and a new list of Y2K safe versions has
been posted to the main Informix web site (http://www.informix.com/). One
lesson from this is that the Y2K information may have to change over time
if bugs are found unexpectedly -- keep an eye on the Y2K information page
at the Informix web site.
This comment came from a well-placed source in the Y2K Project Office:
>The bug was not fixed properly on that platform. The GLS library was not
>recompiled on some platforms because the bug was categorized incorrectly
>as a genlib bug, so they are re-doing the ports. Check the webpage now.
>I think it shows a newer version.
Yours,
Jonathan Leffler (jleffler@informix.com) #include <witticism.h>
Guardian of DBD::Informix v0.60 -- http://www.perl.com/CPAN
Informix IDN for D4GL & Linux -- http://www.informix.com/idn
>Date: Wed, 16 Sep 1998 12:29:49 -0400 (EDT)
>From: "]Steve Berg" <spb@masada.nb.com>
>To: chuanlarp@bigfoot.com
>Subject: Re: Is Informix 7.24.UC5-1 free of Feb 29, 2000 bug (Bug no. 60150).
>
>I am running 7.24.UC5 on a Sequent. I tried Jonathon's example and I got
>the -1204 error. So I would guess it is not fixed in 7.24.UC5.
>
>Steve Berg
>spb@nb.com
>
>On Wed, 9 Sep 1998, Jonathan Leffler wrote:
>> On Wed, 9 Sep 1998, Chuanlarp Satchavarodom wrote:
>> > My system is Informix 7.24.UC5-1. I was wondering whether it is
>> > free of Bug 60150 as mentioned in the following discussion. Any
>> > answers will be appreciated. Thank you very much.
>>
>> Since 7.25.UC5* was released after 7.24.UC4, you should be OK.
>>
>> You can verify that you are OK by testing what happens when you run:
>>
>> DBCENTURY=C DBDATE="dmy4/" dbaccess stores7 - <<!
>> SELECT DATE('29/2/00') FROM SysTables WHERE tabid = 1;
>> !
>>
>> If you get error -1204 (Invalid year in date), then you still have B60150
>> in your code; if you don't get error -1204, then you are OK.
>>
>> I'm testing with 7.24.UC1; it has the bug, as documented by Cristian and June.
>>
>> Cristian wrote:
>> > >Yes, even with DBCENTURY correctly set, the engine fails to recognize
>> > >Feb 29, 2000 as a valid date. Bug no is 60150. First versions that have
>> > >this bug fixed are 7.23.UC9, 7.24.UC4 and 7.30.UC1.
>> >
>> > June Tong wrote:
>> > > Vijay R. Anisetti wrote:
>> > > > I have a 7.22 installation on one machine and 7.23 on another,
>> > > > both are HP boxes. I was checking the Informix documentation
>> > > > regarding the Year 2000 compliance of the Informix-Online Dynamic
>> > > > Server, it says the versions >=7.23.UC9,>=7.24.UC6 are
>> > > > recommended. But, my 7.22.UC1 inteprets DBCENTURY value just like
>> > > > the 7.23.UC5. Is there any difference between the two? Will I be
>> > > > Year 2000 compliant with 7.22.UC1?
>> > >
>> > > Depends on what you mean by "Year 2000 compliant". All versions of
>> > > OnLine are "Year 2000 compliant" in that they do not store years as
>> > > 2 digits. What you get in 7.20 is support for DBCENTURY. If
>> > > Informix is recommending certain versions >7.20, it's probably
>> > > because of bugs in the way DBCENTURY works or interprets certain
>> > > dates (I seem to recall a bug with Feb.29, 2000, and whether it was
>> > > accepted as a leap year or not).