ontape -r to cooked & raw chunks
Posted in 2009
Topics: Backup & Restore, Storage & Space Management, Platform-Specific Issues
i setup 11.5 with rootdbs 20gigs cooked file and a 40gig raw dbspace for all
my databses. After setting up the way i wanted i did a backup "ontape -s -L 0"
then i copied that file over to my other linux server and attempted a ontape
-r . I want to restore to cooked files in the same location on the backup
server, the naming is the same, file perms are the same etc. After 10 mins
maybe it fails with this error . Not sure why this happening exactly. Any
suggestions? Also when doing iostat 5 10 to see if anything is happening i see
not disk activity at all.
Chunks
chk/dbs offset size free bpages flags pathname
1 1 0 10000000 8375259 PO-B /u2/informix/STORAGE/rootdbs
2 2 0 45000000 34308137 PO-B /u2/informix/STORAGE/dbspace1_
chunk1
Continue restore? (y/n)y
Do you want to back up the logs? (y/n)n
Physical restore failed - function write physical restore failed code -1 errno
0
Program over.
Your onstat -d output below shows that the dbspace1_chunk1 chunk is actually
~90GB with ~68GB free. Is it possible that you created the chunk on the
restore target to be only 40GB as you stated on the first line?
Art
On Wed, Mar 18, 2009 at 8:36 PM, JASON HOLOWCHAK <jason@wsex.com> wrote:
> i setup 11.5 with rootdbs 20gigs cooked file and a 40gig raw dbspace for
> all
> my databses. After setting up the way i wanted i did a backup "ontape -s -L
> 0"
> then i copied that file over to my other linux server and attempted a
> ontape> -r . I want to restore to cooked files in the same location on the backup
> server, the naming is the same, file perms are the same etc. After 10 mins
> maybe it fails with this error . Not sure why this happening exactly. Any
> suggestions? Also when doing iostat 5 10 to see if anything is happening i
> see
> not disk activity at all.
>
> Chunks
> chk/dbs offset size free bpages flags pathname
> 1 1 0 10000000 8375259 PO-B /u2/informix/STORAGE/rootdbs
> 2 2 0 45000000 34308137 PO-B /u2/informix/STORAGE/dbspace1_
> chunk1
>
> Continue restore? (y/n)y
> Do you want to back up the logs? (y/n)n
> Physical restore failed - function write physical restore failed code -1
> errno
> 0
>
> Program over.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
--00163646d0865925e204656f8321
Hi,
- how about onstat -d , onstat -D , onstat -g iof
- In that 10 mins, How about iostat, Any movement ?
- ls -l /u2/informix/STORAGE/rootdbs /u2/informix/STORAGE/dbspace1_chunk1
- how about online.log since the restore started
Jakkrit A.
On Wed, Mar 18, 2009 at 8:36 PM, JASON HOLOWCHAK <jason@wsex.com> wrote:
> i setup 11.5 with rootdbs 20gigs cooked file and a 40gig raw dbspace for
> all
> my databses. After setting up the way i wanted i did a backup "ontape -s -L
> 0"
> then i copied that file over to my other linux server and attempted a
> ontape> -r . I want to restore to cooked files in the same location on the backup
> server, the naming is the same, file perms are the same etc. After 10 mins
> maybe it fails with this error . Not sure why this happening exactly. Any
> suggestions? Also when doing iostat 5 10 to see if anything is happening i
> see
> not disk activity at all.
>
> Chunks
> chk/dbs offset size free bpages flags pathname
> 1 1 0 10000000 8375259 PO-B /u2/informix/STORAGE/rootdbs
> 2 2 0 45000000 34308137 PO-B /u2/informix/STORAGE/dbspace1_
> chunk1
>
> Continue restore? (y/n)y
> Do you want to back up the logs? (y/n)n
> Physical restore failed - function write physical restore failed code -1
> errno
> 0
>
> Program over.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
--00163646d0865925e204656f8321
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Hi Guys
Sorry for late timing getting back to this thread. I found the error..
operator error. I didn't add the following to the system that was having
trouble with the restore. i went back through all my steps and this was left
out. Once i added those kernel additions and rebooted the machine the restore
kicked off to the USB drive at a whoping 30megs/sec . After the restore
completed a quick onmode -m to goto multi user mode and things were looking
good. I really don't know which kernel level parameter was causing this , if i
get time i will add one by one to check.
Add this to /etc/sysctl.conf
kernel.shmmax = 4398046511104
kernel.shmmin = 1
kernel.shmmni = 4096
kernel.shmseg = 128
kernel.shmall = 4194304
kernel.semmni = 4096
kernel.semmsl = 250
kernel.semmns = 32000
kernel.semopm = 32
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape