Re: Informix doesn't start after reboot
Posted in 2005
On Thursday 10 November 2005 16:03, mostrostro@gmail.com wrote:
> I'm using IDS_9.30.UC2.
> I've just upgraded to kernel 2.6.8 and I've got the same output.
> The problem is that I need to use this version, so I can't upgrade IDS!
>
> :-(
>
> I've also tried to install IDS on a Fedora Core 3 system, but I've got
> this error message when I try to launch oninit:
>
> oninit: relocation error: /var/lib/libpthread.so.0: symbol _h_errno,
> version GLIBC_2.0 not defined in file libc.so.6 with link time
> reference
IDS 9.30.UC2 delivers its own version of /var/lib/libpthread.so.0 which is
not compatible with new glibc versions. But the new glibc versions i686 or
tls deliver the required functionality by default. Thats why you can move
the symbolic link /var/lib/libpthread.so.0 away, e.g.
mv /var/lib/libpthread.so.0 /var/lib/libpthread.so.0.ifmx
Andreas
>
> I've installed compat-glibc-6.2-2.1.3.2.i386, but it seems that oninit
> can't find the compability libraries.
sending to informix-list