Enterprise replication errors
Posted in 2007
Topics: High Availability & Replication, Platform-Specific Issues
Hi, I'm setting up Enterprise Replication as a primary target between 2 servers I've defined my replicate servers and my replicates and started the replication. When I update a record on the master, the information is sent to the slave server. However, the transaction is rejected and logged into the ATS and RIS directories with the following error message: TXH CDR:45 (Error: Could not read from received stream.) / SQL:0 / ISAM:0 Any idea? Informix 10 as DB Server and Solaris 10 as OS Thanks
Generally this indicates a mismatch in the data layout between the sour= ce and the target. Possibably a difference in the schemas. Are these mastered replicates? M.P. = "GEORGES MARTIN" = <georges_martin_1 = @hotmail.com> = To Sent by: ids@iiug.org = ids-bounces@iiug. = cc org = Subj= ect Enterprise replication errors = 03/29/2007 12:57 [8758] = PM = = = Please respond to = ids@iiug.org = = = Hi, I'm setting up Enterprise Replication as a primary target between 2 ser= vers I've defined my replicate servers and my replicates and started the replication. When I update a record on the master, the information is sent to the sl= ave server. However, the transaction is rejected and logged into the ATS an= d RIS directories with the following error message: TXH CDR:45 (Error: Could not read from received stream.) / SQL:0 / ISAM= :0 Any idea? Informix 10 as DB Server and Solaris 10 as OS Thanks ***********************************************************************= ******** Forum Note: Use "Reply" to post a response in the discussion forum. =
Hello, To isolate the problem, following info might help. What type of database logging you are using ? - ansi, buffered or unbuffered. How did you defined replicates ? using 'cdr define template' or using 'cdr define repl' Regards, - Nilesh - "GEORGES MARTIN" <georges_martin_1@hotmail.com> Sent by: ids-bounces@iiug.org 03/29/2007 12:57 PM Please respond to ids@iiug.org To ids@iiug.org cc Subject Enterprise replication errors [8758] Hi, I'm setting up Enterprise Replication as a primary target between 2 servers I've defined my replicate servers and my replicates and started the replication. When I update a record on the master, the information is sent to the slave server. However, the transaction is rejected and logged into the ATS and RIS directories with the following error message: TXH CDR:45 (Error: Could not read from received stream.) / SQL:0 / ISAM:0 Any idea? Informix 10 as DB Server and Solaris 10 as OS Thanks ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.