setnet and IDS 9.4: Connection problems
Posted in 2003
Topics: Installation, Setup & Upgrades, Server Administration, Security, Permissions & Auditing, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
Hi,
I installed the IDS 9.4 found in IIUG, configured it (just for a brief
test), started it, created a new database, and everything was fine.
I can connect via shared memory or soctcp with dbaccess with no problem, BUT
when I try to connect via setnet with dbping, I only get error -908 with
sqlstate 08004. I've the latest Informix Client SDK (setnet & co)
available, freshly downloaded today.
The firewall is disabled in RedHat and I can ping, ftp, use a shared folder
with samba or ssh with PuTTY with no problems.
I must say also, that I'm new to Linux, and I'm not sure if the changes to
the kernel parameters where correct (the ones that I found, not the ones
that I've never seen like SEMMNI).
Please, can somebody help me !!! Thanks in advance !!!
In setnet I have
User Name: informix
Password: *mine*
Informix Server: idslinuxnet
Host Name: 146.146.0.1
Service: 5555
Protocol: onsoctcp
Database: prueba
[informix@RedHat etc]$ uname -a
Linux RedHat.XCellent.com 2.4.20-8 #1 Thu Mar 13 17:18:24 EST 2003 i686
athlon i386 GNU/Linux
Manuel Daponte wrote:
>Hi,
>
>I installed the IDS 9.4 found in IIUG, configured it (just for a brief
>test), started it, created a new database, and everything was fine.
>
>I can connect via shared memory or soctcp with dbaccess with no problem, BUT
>when I try to connect via setnet with dbping, I only get error -908 with
>sqlstate 08004. I've the latest Informix Client SDK (setnet & co)
>available, freshly downloaded today.
>
>The firewall is disabled in RedHat and I can ping, ftp, use a shared folder
>with samba or ssh with PuTTY with no problems.
>
>I must say also, that I'm new to Linux, and I'm not sure if the changes to
>the kernel parameters where correct (the ones that I found, not the ones
>that I've never seen like SEMMNI).
>
>Please, can somebody help me !!! Thanks in advance !!!
>
>In setnet I have
>User Name: informix
>Password: *mine*
>Informix Server: idslinuxnet
>Host Name: 146.146.0.1
>Service: 5555
>
Do you have an entry in Windoze services file to match the entry on linux or
did you just enter 5555 into service in setnet?
I always made an entry into hosts and services on Windoze to match *nix
side.
Maybe that's it.
HTH
Michael
>Protocol: onsoctcp
>Database: prueba
>
>[informix@RedHat etc]$ uname -a
>Linux RedHat.XCellent.com 2.4.20-8 #1 Thu Mar 13 17:18:24 EST 2003 i686
>athlon i386 GNU/Linux
>
>From ifconfig
>eth0 Link encap:Ethernet HWaddr 00:01:03:2B:4D:B3
> inet addr:146.146.0.1 Bcast:146.146.0.255 Mask:255.255.255.0
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> RX packets:360 errors:0 dropped:0 overruns:0 frame:0
> TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:100
> RX bytes:44869 (43.8 Kb) TX bytes:5126 (5.0 Kb)
> Interrupt:5 Base address:0x9400
>
>From /etc/profile
>export INFORMIXDIR=/opt/informix
>export ONCONFIG=onconfig.idslinux
>export INFORMIXSERVER=idslinuxshm>export DBEDIT=vi
>PATH=$PATH:$INFORMIXDIR/bin>
>From $ONCONFIG
>DBSERVERNAME idslinuxshm # Name of default database server
>DBSERVERALIASES idslinuxnet # List of alternate dbservernames
>NETTYPE ipcshm,1,15,CPU # Configure poll thread(s) for nettype
>NETTYPE soctcp,1,15,CPU # Configure poll thread(s) for nettype>
>From sqlhosts
>idslinuxshm onipcshm RedHat sqlexec
>idslinuxnet onsoctcp RedHat redhatids>
>From /etc/services
>redhatids 5555/tcp # Informix Dynamic Server
>
>From onstat -
>Informix Dynamic Server Version 9.40.UC1E1 -- On-Line -- Up 00:27:01 --
>28208 Kbytes
>
>
>
>
>
>
>
>
>