Problem with IDS 11 DataBlades
Posted in 2007
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration, Platform-Specific Issues
HP-UX 11.23
IDS 11.10.FC1
I am doing some testing on an IDS 11 instance. I wanted to try the
Node DataBlade out. When I go to blademgr to register it, I have
problems. If I do:
list [databasename]
I get: blademgr: ERROR: Prepare failed in current database.
My message log also says:
15:01:19 Loading Module <$INFORMIXDIR/extend/ifxmngr/ifxmngr.bld>
15:01:19 (-9720): ERROR: Loading Module <$INFORMIXDIR/extend/ifxmngr/
ifxmngr.bld>
I have the actual $INFORMIXDIR/extend in my DB_LIBRARY_PATH in my
onconfig. (I also tried using the exact string "$INFORMIXDIR/extend")
In all cases the errors in the message log were the same. I bounced
the instance to make sure that it could notice the changes, if needed.
I set LD_LIBRARY_PATH and SHLIB_PATH to include $INFORMIXDIR/lib and
$INFORMIXDIR/lib/esql.
I tried to just go ahead and register the blade, but I get this:
blademgr: ERROR: Prepare failed in current database.
blademgr: ERROR: Couldn't 'prep' database.
Any ideas?
On Sep 18, 3:09 pm, The Durster <seandur...@gmail.com> wrote:
> HP-UX 11.23
> IDS 11.10.FC1
>
> I am doing some testing on an IDS 11 instance. I wanted to try the
> Node DataBlade out. When I go to blademgr to register it, I have
> problems. If I do:
> list [databasename]
> I get: blademgr: ERROR: Prepare failed in current database.
> My message log also says:
> 15:01:19 Loading Module <$INFORMIXDIR/extend/ifxmngr/ifxmngr.bld>
> 15:01:19 (-9720): ERROR: Loading Module <$INFORMIXDIR/extend/ifxmngr/
> ifxmngr.bld>>
> I have the actual $INFORMIXDIR/extend in my DB_LIBRARY_PATH in my
> onconfig. (I also tried using the exact string "$INFORMIXDIR/extend")
> In all cases the errors in the message log were the same. I bounced
> the instance to make sure that it could notice the changes, if needed.
>
> I set LD_LIBRARY_PATH and SHLIB_PATH to include $INFORMIXDIR/lib and
> $INFORMIXDIR/lib/esql.
>
> I tried to just go ahead and register the blade, but I get this:
> blademgr: ERROR: Prepare failed in current database.
> blademgr: ERROR: Couldn't 'prep' database.
>
> Any ideas?
I changed the new IFX_EXTEND_ROLE parameter to 0 and everything was
fine. Apparently, when on, it limits who can install extensions (ie
DataBlades). I don't know where you set up the proper users, but this
should point others who run into this in the right direction.
Thanks for the replies off-list. They didn't nail the problem, but I
appreciate the quick help.
Some cut and paste from helpful replies so that others may find help here: "you need to use the exact string "$INFORMIXDIR/extend" in DB_LIBRARY_PATH because that's the path that gets used at database creation time when all the ancillary external procedures that blade manager uses get created. However, if you turn off DB_LIBRARY_PATH and still have problems loading ifmxmngr.bld that ain't your problem. maybe permission problems on the actual shared object? LD_LIBRARY_PATH wouldn't be your problem because the language manager passes the full path to the shared object to dlopen()" [After turning off DB_LIBRARY_PATH and also trying the "$INFORMIXDIR/ extend" exact string for DB_LIBRARY_PATH with neither producing success] "Well, then DB_LIBRARY_PATH isn't your problem. Unluckily the language manager uses the same error number for all possible loading errors, so you'd get a 9720 if the shared object wasn't found, or wasn't executable, was owned by root and the engine had the wrong permissions (ie not owned by root:informix, setuid/gid), and quite possibly if the extend role is enabled, although if memory serves me well the database dba and informix always have the extend role granted" thanks again for the quick responses and help.
I ran into the exact same problem registering the spatial datablade
today. Your answer resolved my problem; IFX_EXTEND_ROLE was set to 1.
If you find anything more about DB users and the IFX_EXTEMD_ROLE, please
pass it along.
Thanks for your summary.
Mike
> -----Original Message-----
> From: informix-list-bounces@iiug.org
> [mailto:informix-list-bounces@iiug.org] On Behalf Of The Durster
> Sent: Tuesday, September 18, 2007 1:51 PM
> To: informix-list@iiug.org
> Subject: Re: Problem with IDS 11 DataBlades
>
> On Sep 18, 3:09 pm, The Durster <seandur...@gmail.com> wrote:
> > HP-UX 11.23
> > IDS 11.10.FC1
> >
> > I am doing some testing on an IDS 11 instance. I wanted to try the
> > Node DataBlade out. When I go to blademgr to register it, I have
> > problems. If I do:
> > list [databasename]
> > I get: blademgr: ERROR: Prepare failed in current database.
> > My message log also says:
> > 15:01:19 Loading Module <$INFORMIXDIR/extend/ifxmngr/ifxmngr.bld>
> > 15:01:19 (-9720): ERROR: Loading Module
> <$INFORMIXDIR/extend/ifxmngr/
> > ifxmngr.bld>> >
> > I have the actual $INFORMIXDIR/extend in my DB_LIBRARY_PATH in my
> > onconfig. (I also tried using the exact string
> "$INFORMIXDIR/extend")
> > In all cases the errors in the message log were the same. I bounced
> > the instance to make sure that it could notice the changes,
> if needed.
> >
> > I set LD_LIBRARY_PATH and SHLIB_PATH to include
> $INFORMIXDIR/lib and
> > $INFORMIXDIR/lib/esql.
> >
> > I tried to just go ahead and register the blade, but I get this:
> > blademgr: ERROR: Prepare failed in current database.
> > blademgr: ERROR: Couldn't 'prep' database.
> >
> > Any ideas?
>
> I changed the new IFX_EXTEND_ROLE parameter to 0 and
> everything was fine. Apparently, when on, it limits who can
> install extensions (ie DataBlades). I don't know where you
> set up the proper users, but this should point others who run
> into this in the right direction.
>
> Thanks for the replies off-list. They didn't nail the
> problem, but I appreciate the quick help.
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
>