Enterprise Replication Error
Posted in 2005
Topics: High Availability & Replication, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi, I am using informix 7.31 on HP-UX B.11.11 U for Replication setup. I am facing the a problem during the setup. The details of the setup are as I have two hosts dhl-3l and dhl-6a Sqlhosts on dhl-3l cia32_3l group - - i=125 cia32_1 onsoctcp 16.138.144.68 cia32_soc g=cia32_3l cia32_6a group - - i=126 cia32_2 onsoctcp 16.138.144.70 cia32_soc1 g=cia32_6a Sqlhosts on dhl-6a cia32_6a group - - i=126 cia32_2 onsoctcp 16.138.144.70 cia32_soc1 g=cia32_6a cia32_3l group - - i=125 cia32_1 onsoctcp 16.138.144.68 cia32_soc g=cia32_3l I have made both the servers online and gave the commands from dhl-3l as 1) cdr define server --init cia32_3l 2) cdr define server -c cia32_6a -I -S cia32_3l cia32_6a the errors in the log of dhl-6a are as follows 12:14:15 Building 'syscdr' database ... 12:14:15 'syscdr' database built successfully. 12:14:16 CDR queuer initialization complete 12:14:16 CDR connection to server lost, id 125, name <cia32_3l> Reason: Connect failed reason: 7 12:14:16 CDR GC: operation sync connect failed (error 5). 12:14:16 CDR GC: synchronization failed (sync abort, shutting down CDR) 12:14:16 CDR NIF Shutdown: connections all shutdown. 12:14:16 CDR The NIF sub-component has shut down. 12:14:16 CDR shutdown complete Please tell me if i am doing something wrong. bye.
You should make sure that user informix is trusted on each server,
from
the other server. In other words, user informix should be trusted on
dhl-3l when it is coming from dhl-6a and vice versa. The appropriate
entry should be added to the /etc/hosts.equiv file.
The best way I found to verify this is to open dbaccess on one of the
servers, let's say dhl-3l, as user informix with your environment
pointing to the instance on dhl-3l. From the menu select Connection,
then select Connect. Then highlight the group server name that resides
on dhl-6a and press enter. When asked for the user name, simply press
enter. You should then see a list of the databases in the instance on
dhl-6a. If user informix coming from dhl-31 is not trusted on dhl-6a
then you will see an error message at the bottom of the screen telling
you that user informix@dhl-31 is not trusted on that server. If this is
the case, you need to add an entry in /etc/hosts.equiv file on dhl-6a
similar to the following:
dhl-31 informix
A good rule of thumb is to indicate the host name exactly as it is shown
in the error message. Depending on how your HP network is configured,
it could be case sensitive - not always, but it's best to enter the host
name exactly as it is in the error message.
You then need to verify the connection the other way around, i.e.,
reverse the host names in the above steps. I found that with ER in IDS
7.31, all hosts involved in a replication scheme need to know about
(sqlhosts) and trust (/etc/hosts.equiv) all other participants in the
replication scheme.
I hope this wasn't too complicated. ER can be intimidating. Good luck.
Rob Schmitz
Rob.B.Schmitz@mail.sprint.com
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
Behalf Of PARAMESHWAR....
Sent: Wednesday, January 19, 2005 1:29 AM
To: ids@iiug.org
Subject: Enterprise Replication Error [4041]
Hi,
I am using informix 7.31 on HP-UX B.11.11 U for Replication setup. I am
facing the a problem during the setup.
The details of the setup are as
I have two hosts dhl-3l and dhl-6a
Sqlhosts on dhl-3l
cia32_3l group - - i=125
cia32_1 onsoctcp 16.138.144.68 cia32_soc g=cia32_3l
cia32_6a group - - i=126
cia32_2 onsoctcp 16.138.144.70 cia32_soc1 g=cia32_6a
Sqlhosts on dhl-6a
cia32_6a group - - i=126
cia32_2 onsoctcp 16.138.144.70 cia32_soc1
g=cia32_6a
cia32_3l group - - i=125
cia32_1 onsoctcp 16.138.144.68 cia32_soc
g=cia32_3l
I have made both the servers online and gave the commands from dhl-3l as
1) cdr define server --init cia32_3l
2) cdr define server -c cia32_6a -I -S cia32_3l cia32_6a
the errors in the log of dhl-6a are as follows
12:14:15 Building 'syscdr' database ...
12:14:15 'syscdr' database built successfully.
12:14:16 CDR queuer initialization complete
12:14:16 CDR connection to server lost, id 125, name <cia32_3l>
Reason: Connect failed reason: 7
12:14:16 CDR GC: operation sync connect failed (error 5). 12:14:16 CDR
GC: synchronization failed (sync abort, shutting down CDR) 12:14:16 CDR
NIF Shutdown: connections all shutdown. 12:14:16 CDR The NIF
sub-component has shut down. 12:14:16 CDR shutdown complete
Please tell me if i am doing something wrong.
bye.