Informix KAIO Error
Posted in 2006
Topics: Error Codes & Troubleshooting, Platform-Specific Issues
Hi people !!
I have a problem with Informix 7.31 with HP-UX 11i, during the KAIO
initialization.
Following the online.log
Tue Jul 4 08:57:38 2006
08:57:38 Event alarms enabled. ALARMPROG =
'/sgbd/informix/etc/log_full.sh'
08:57:44 DR: DRAUTO is 0 (Off)
08:57:44 Informix Dynamic Server Version 7.31.UC7 Software SerialNumber AAC#J955102
08:57:44 Can't open /dev/async. KAIO disabled
08:57:44 Assert Failed: kaiothread() ERROR
08:57:44 Informix Dynamic Server Version 7.31.UC7
08:57:44 Who: Session(0, @, 0, 0)
Thread(54, kaio, 0, 8)
File: kaio.c Line: 2141
08:57:44 stack trace for pid 3757 written to /sgbd/informix/af.41e57b7
08:57:46 See Also: /sgbd/informix/af.41e57b7
08:57:46 kaio.c, line 2141, thread 54, proc id 3757, kaiothread()
ERROR.
08:57:46 PANIC: Attempting to bring system down
Anybody can help me, please !!!
Tks,
Eduardo
cboccio@yahoo.com.br wrote:
> Hi people !!
>
> I have a problem with Informix 7.31 with HP-UX 11i, during the KAIO
> initialization.
> Following the online.log
>
> Tue Jul 4 08:57:38 2006
>
> 08:57:38 Event alarms enabled. ALARMPROG =
> '/sgbd/informix/etc/log_full.sh'
> 08:57:44 DR: DRAUTO is 0 (Off)
> 08:57:44 Informix Dynamic Server Version 7.31.UC7 Software Serial> Number AAC#J955102
> 08:57:44 Can't open /dev/async. KAIO disabled
> 08:57:44 Assert Failed: kaiothread() ERROR
> 08:57:44 Informix Dynamic Server Version 7.31.UC7
> 08:57:44 Who: Session(0, @, 0, 0)
> Thread(54, kaio, 0, 8)
> File: kaio.c Line: 2141
> 08:57:44 stack trace for pid 3757 written to /sgbd/informix/af.41e57b7
>
> 08:57:46 See Also: /sgbd/informix/af.41e57b7
> 08:57:46 kaio.c, line 2141, thread 54, proc id 3757, kaiothread()
> ERROR.
> 08:57:46 PANIC: Attempting to bring system down>
> Anybody can help me, please !!!
>
> Tks,
>
> Eduardo
>
Check your Machine Notes ...
http://www-306.ibm.com/software/data/informix/pubs/library/notes/machnote/hpmn_731UC7A.txt
2. Kernel Asynchronous I/O (KAIO) is supported on this platform. However, it
is DISABLED by default. To enable KAIO set the environment variable
KAIOON. It is only effective on raw partitions.
KAIOON=1; export KAIOON (for Bourne or Korn Shell)
setenv KAIOON 1 (for C Shell)
The following is a pre-requisite for using KAIO:
o. HP KAIO driver "asyncdsk" is installed and linked into the
kernel.
o. To ensure KAIO driver is up and running, check to see if there
is /dev/async, if not follow these steps:
1) su root
2) /usr/sbin/mknod /dev/async c 101 4
3) chmod 0666 /dev/async
TBP,
I done the steps that you sent me (set KAIOON=1 and install asyncdsk),
but the error still the same
What can I do to solve this problem ?
Tks,
Regards,
Eduardo
TBP escreveu:
> cboccio@yahoo.com.br wrote:
> > Hi people !!
> >
> > I have a problem with Informix 7.31 with HP-UX 11i, during the KAIO
> > initialization.
> > Following the online.log
> >
> > Tue Jul 4 08:57:38 2006
> >
> > 08:57:38 Event alarms enabled. ALARMPROG =
> > '/sgbd/informix/etc/log_full.sh'
> > 08:57:44 DR: DRAUTO is 0 (Off)
> > 08:57:44 Informix Dynamic Server Version 7.31.UC7 Software Serial> > Number AAC#J955102
> > 08:57:44 Can't open /dev/async. KAIO disabled
> > 08:57:44 Assert Failed: kaiothread() ERROR
> > 08:57:44 Informix Dynamic Server Version 7.31.UC7
> > 08:57:44 Who: Session(0, @, 0, 0)
> > Thread(54, kaio, 0, 8)
> > File: kaio.c Line: 2141
> > 08:57:44 stack trace for pid 3757 written to /sgbd/informix/af.41e57b7
> >
> > 08:57:46 See Also: /sgbd/informix/af.41e57b7
> > 08:57:46 kaio.c, line 2141, thread 54, proc id 3757, kaiothread()
> > ERROR.
> > 08:57:46 PANIC: Attempting to bring system down> >
> > Anybody can help me, please !!!
> >
> > Tks,
> >
> > Eduardo
> >
> Check your Machine Notes ...
>
> http://www-306.ibm.com/software/data/informix/pubs/library/notes/machnote/hpmn_731UC7A.txt
>
> 2. Kernel Asynchronous I/O (KAIO) is supported on this platform. However, it
> is DISABLED by default. To enable KAIO set the environment variable
> KAIOON. It is only effective on raw partitions.
>
>
> KAIOON=1; export KAIOON (for Bourne or Korn Shell)
>
>
> setenv KAIOON 1 (for C Shell)
>
>
> The following is a pre-requisite for using KAIO:
>
>
> o. HP KAIO driver "asyncdsk" is installed and linked into the
> kernel.
>
>
> o. To ensure KAIO driver is up and running, check to see if there
> is /dev/async, if not follow these steps:
>
>
> 1) su root
> 2) /usr/sbin/mknod /dev/async c 101 4
> 3) chmod 0666 /dev/async
cboccio@yahoo.com.br wrote:
> TBP,
>
> I done the steps that you sent me (set KAIOON=1 and install asyncdsk),
> but the error still the same
>
> What can I do to solve this problem ?
>
> Tks,
>
> Regards,
>
> Eduardo
>
>
> TBP escreveu:
>
>> cboccio@yahoo.com.br wrote:
>>> Hi people !!
>>>
>>> I have a problem with Informix 7.31 with HP-UX 11i, during the KAIO
>>> initialization.
>>> Following the online.log
>>>
>>> Tue Jul 4 08:57:38 2006
>>>
>>> 08:57:38 Event alarms enabled. ALARMPROG =
>>> '/sgbd/informix/etc/log_full.sh'
>>> 08:57:44 DR: DRAUTO is 0 (Off)
>>> 08:57:44 Informix Dynamic Server Version 7.31.UC7 Software Serial>>> Number AAC#J955102
>>> 08:57:44 Can't open /dev/async. KAIO disabled
>>> 08:57:44 Assert Failed: kaiothread() ERROR
>>> 08:57:44 Informix Dynamic Server Version 7.31.UC7
>>> 08:57:44 Who: Session(0, @, 0, 0)
>>> Thread(54, kaio, 0, 8)
>>> File: kaio.c Line: 2141
>>> 08:57:44 stack trace for pid 3757 written to /sgbd/informix/af.41e57b7
>>>
>>> 08:57:46 See Also: /sgbd/informix/af.41e57b7
>>> 08:57:46 kaio.c, line 2141, thread 54, proc id 3757, kaiothread()
>>> ERROR.
>>> 08:57:46 PANIC: Attempting to bring system down>>>
>>> Anybody can help me, please !!!
>>>
>>> Tks,
>>>
>>> Eduardo
>>>
Go into SAM / Kernel Parameters / Drivers and check what you have under
asyncdisk for ...
Current State
Pending State
Looks a bit odd to have "KAIO disablsed".