Re: What happens when a table has over 200 extents?
Posted in 1995
} @access1.digex.net (Lester Knutsen) writes: } |> I have a site with a very large and fragmented database. One table } |> has over 170 extents, and many have over 8 extents. The database } |> is in use 6 days a week, 24 hours. I need to justify taking the } |> database down for a few days to fix things. A couple of questions. } |> } |> Does anyone know what happens when you go over the max number of } |> extents for a table? Does everything stop working or just } |> adding rows to one table? I would really like hear from anyone } |> who has gone over the max number of extents. } } [...] } Once you hit your max, you could not allocate any more extents. } If the rest of them were full, you would not be able to add any rows to } your table. You would get error } -131 ISAM error: no free disk space. The last time I did this I got error -136 ISAM error: no more extents. You should still be able to read, just not add more rows. If you delete some existing rows, then you can add new ones. As long as you don't need to get another extent. If the table is in your root dbspace (we all know better than this, right?) then you will have many additional problems. } [...] } |> What kind of performance gain should we expect from fixing } |> the extents? 10%, 20%, etc ...?? } } I'd be surprised if you got as much as 10%, but your mileage may very well } vary. } } Dave Kosenko Same here. It is an application-specific gain, but only incremental at best. Performance gains on databases are like mileage gains on cars. You start out with 20mpg, gain 20% here, 10% there, and 30% the other place and wind up with 25mpg. Go figure. __________________________________________________________________ | Clem Akins Standard Disclaimers Apply | |Reynolds Metals Co, Alloys Plant "Climb High, Cave Deep!" | | Muscle Shoals, Alabama USA cwakins@leia.alloys.rmc.com | |________________________________________________________________|