This error will occur if you have done an express-mode high performance load
job.
You must archive the dbspace the data was written to before you can write to
that dbspace.
-Dave
David Buchholz
Senior DBA
Vital Processing Services
-----Original Message-----
From: malc_p@btinternet.com [mailto:malc_p@btinternet.com]
Sent: Tuesday, December 23, 2003 9:39 AM
To: informix-list@iiug.org
Subject: Spurious error 197?
IDS9.30HC5, HPUX 11i, 4GL 7.20
Just had this on one of our test systems when writing to a table:
=====================================================================
-197 ISAM error: Partition recently appended to; can't open for
write or logging.
If this internal error recurs, please note all circumstances and
contact Technical Support at tsmail@us.ibm.com.
=====================================================================
.... but we haven't added any chunks or anything. Tried a checkpoint
and a logical log (Oh how the immature techies laugh when you tell
them you're going to force a log to see what happens. sigh.) but still
got the error (both INSERT and UPDATE); it cleared when I did a
level-0 to /dev/null. There are no blobs or varchars or anything nasty
on the table, and no untoward messages in the online log - the
instance has been up happily for the last week.
Anyone seen this before? I'll raise a tech support case but they won't
be that interested as the fault has cleared up.
Cheers
Malc
sending to informix-list