Re: HELP: Can't Drop DBSpace
Posted in 1998
In article <01bd9b31$4f810440$35c8798b@TimWollin.hctg.saic.com>, Tim
<TIMOTHY.WOLLIN@cpmx.saic.com> writes
>Hi,
>
>We had a disk drive go bad. After replacing the disk a restore of a backup
>was performed. The restore was successful except for one dbspace
>(dbs_dyn2). There is only one table in this dbspace and the data is
>retrievable via an audit table in another dbspace. The problem is that I
>can not drop the exisiting table in this dbspace nor can I drop the
>dbspace. The follow error occurs when trying to drop the dbspace.
>
># tbspaces -d dbs_dyn2
>WARNING: Dropping a dbspace/BLOBSpace.
>Do you really want to continue? (y/n) y
>Cannot drop the dbspace/BLOBSpace.
>ISAM error: bad isam file format.>
>I need to be able to drop the table to re-create it and populate it from
>the audit table. The version of Informix On-Line is 5.1. If anyone can
>help with this It would be greatly appreciated.
>
Talk to Informix Technical Support...
>Thanks.
>Tim Wollin
>TIMOTHY.WOLLIN@cpmx.saic.com
>
--
David Williams
Maintainer of the Informix FAQ
Primary site (Beta Version) http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html
I see you standin', Standin' on your own, It's such a lonely place for you, For
you to be If you need a shoulder, Or if you need a friend, I'll be here
standing, Until the bitter end...
So don't chastise me Or think I, I mean you harm...
All I ever wanted Was for you To know that I care