Re: < oninit -i >"Fatal error in Shared memory"
Posted in 1999
Dave,
As everyone else has said, check your log first. But also a good idea
when you're not sure is < onstat - >. Sometimes this shows that something
is actually there, but I trust not in your case. Anyway, last but not
least, if you can, check to see if Informix has left segments in memory,
using < ipcs >. If so, you'll need to remove them with < ipcrm >. Another
annoying thing, at least with me, is sockets that are forever trying to
dry up and will not let you initialise because "shared memory cannot bind
to network", and you'll see this message also in your log file.
Hope this helps,
Nick
On Fri, 21 May 1999, Dave wrote:
> Hi
>
> We 're using informix on an solaris 2.6 platform, but we 're having
> the following message after the < oninit -i > command
> "Fatal error in Shared memory"
>
> The shared memory settings in both the /etc/system and the
> $INFORMIXDIR/etc/onconfig file seem ok.
>
> What could be wrong? The damn thing worked 2 days ago
> without any problems, I even reinstalled the whole machine from
> scratch with the same result.
>
> HELP
>
> David.Govaert@Teleatlas.com
>
>