RAID 1 for critical dbspaces...
Posted in 2003
Topics: Performance & Tuning, Storage & Space Management
Hello all, We are moving from RAID10 to RAID5 with our new storage array. Now until now with RAID10, we have all our database volumes mirrored. When we go for RAID 5, The following questions arise and i would like to clarify regarding that. If we go for RAID 5, 1) Do we have to mirror our critical dbspaces either at the database level or have to create critical dbspace volumes on RAID1 ? 2) Does the RAID5 recovery mechanism not recover the data even for critical dbspaces ? 3) Why do most of the white papers recommend RAID1 for critical dbspaces even if we go for RAID 5 for data dbspaces ? 4) The I/O request will never fail even with RAID5, right ? I agree that there will be a performance degradation in RAID5 higher than RAID1 during the disaster recovery phase,should the critical dbspaces mirroring mandatory if we go for RAID5 for data dbspaces ? Your comments are appreciated. Rajesh Rajasekaran Informix Database Administrator Forest Pharmaceuticals Inc. (314) 493-7073 rrajasekaran@forestpharm.com sending to informix-list
On Thu, 31 Jul 2003 14:44:25 -0400, Rajasekaran, Rajesh wrote: NO RAID5 NO RAID5 NO RAID5 NO RAID5 NO RAID5 NO RAID5 NO RAID5 NO RAID5 > Hello all, > > We are moving from RAID10 to RAID5 with our new storage array. Now > until > now with RAID10, we have all our database volumes mirrored. When we go > for RAID 5, The following questions arise and i would like to clarify > regarding that. Why in the name of all that's holy would you go and do that!?!??! Didn't I teach you better? > If we go for RAID 5, > > 1) Do we have to mirror our critical dbspaces either at the database > level or have to create critical dbspace volumes on RAID1 ? Only if you like performance, data security and safety, and your job. > 2) Does the RAID5 recovery mechanism not recover the data even for > critical dbspaces ? RAID5 does not recover from ANYTHING except a catastrophic single drive failure which, hopefully, occurs before the media begins to degrade on one of the remaining drives. > 3) Why do most of the white papers recommend RAID1 for critical dbspaces > even if we go for RAID 5 for data dbspaces ? They're critical, right? And RAID1 is far more secure and faster than RAID5. > 4) The I/O request will never fail even with RAID5, right ? HAHHAHAHAHHAHAHAH. When we used RAID5 for databases I was awakened at least 2 nights a week by one of: - Spurious error from the RAID Array following a correctly recovered drive failure (ie the failed drive's data was correctly returned but the array reported an error anyway). - Trashed index (about 1/2 due to unlogged databases and the rest due to partial media failure trashing the RAID5 array without warning). - Spurious errors from the RAID Array when one of three redundant power supplies died, even though power was still flowing from the other two. - Spurious errors from the RAID Array when one of four redundant controllers failed. Since switching to RAID10 5 years ago NONE of these errors has recurred and believe me we've lost our share of drives, power supplies, and controllers over this period. The only thing waking me up for the next year until I convinced everyone we needed to log the databases were trashed indexes. Since then only hard crashes have trashed an index and I've never gotten a call for a down chunk that was not caused by some hardware tech kicking a plug out or turning off the wrong disk cabinet. > I agree that there will be a > performance degradation in RAID5 higher than RAID1 during the disaster > recovery phase,should the critical dbspaces mirroring mandatory if we go > for RAID5 for data dbspaces? That's like asking, "If I stand in the middle of 5th Avenue in New York at noon should I shine my shoes?". Sounds like it's past time for my NO RAID5 rant. I'll repost it shortly, look for it. Art S. Kagel > Your comments are appreciated. > > Rajesh Rajasekaran > Informix Database Administrator > Forest Pharmaceuticals Inc. > (314) 493-7073 > rrajasekaran@forestpharm.com > > sending to informix-list
"Rajasekaran, Rajesh" <RRajasekaran@forestpharm.com> wrote in message news:bgbppd$qtd$1@terabinaries.xmission.com... > > Hello all, > > We are moving from RAID10 to RAID5 with our new storage array. Oh no! set mode KAGEL=RANT ......
"Art S. Kagel" <kagel@bloomberg.net> writes: > Since switching to RAID10 5 years ago NONE of these errors has recurred > and believe me we've lost our share of drives, power supplies, and > controllers over this period. ... > Sounds like it's past time for my NO RAID5 rant. I'll repost it shortly, > look for it. Ok, I'm convinced to switch from RAID1 to RAID10. I have a PowerEdge 1750 with hardware RAID 0, 1, and 5 on it's SCSI controller. How do I configure it for RAID10? Or am I stuck with RAID1? -- Forte International, P.O. Box 1412, Ridgecrest, CA 93556-1412 Ronald Cole <ronald@forte-intl.com> Phone: (760) 499-9142 President, CEO Fax: (760) 499-9152 My GPG fingerprint: C3AF 4BE9 BEA6 F1C2 B084 4A88 8851 E6C8 69E3 B00B