Re: Visual Cafe for Java and Informix SE7.2
Posted in 1998
In article <MPG.f3ea68398b18df0989681@sanfrancisco01.news.internex.net>, Gerald B. Rosenberg <gbr@fdml.com> writes >I am trying to get VCJdbDE to work with SE7.2, both running on an NT 4.0 >Workstation. DBAccess is able to connect and perform db operations as >expected. dbAnywhere, however, gives a -26696 error whenever I use >Help->Test Data Sources. > >Feb 01 15:27:51 Running. >Feb 01 15:28:07 Logging onto the server '192.168.70.1' >Feb 01 15:28:07 Opening the database 'fdml' ... >Feb 01 15:28:08 Informix Error Code: -25596 >The INFORMIXSERVER value is not listed in the sqlhosts file or the >Registry. > >But the INFORMIXSERVER value is correctly listed! > >This happens when I use either the seipcpip or sesoctcp protocols. > I saw this with WGS on SCO 5.0.4 the other day. The last column in sqlhosts is the 'service'. Make sure this is in /etc/services EVEN IF YOU ARE NOT USING A NETWORK CONNECTION. I was using onipcshm but it would still complain that INFORMIXSERVER did not match DBSERVERNAME or DBSERVERALIASES in the ONCONFIG file.. When I added the entry to /etc/services it worked!! >Has anyone else gotten this configuration to run correctly? I would sure >appreciate any suggestions as to what dbAnywhere's problem is and how to >fix it. > >Thanks, >Gerald > -- David Williams Maintainer of the Informix FAQ Primary site (Beta Version) http://www.smooth1.demon.co.uk Official site http://www.iiug.org/techinfo/faq/faq_top.html I see you standin', Standin' on your own, It's such a lonely place for you, For you to be If you need a shoulder, Or if you need a friend, I'll be here standing, Until the bitter end... So don't chastise me Or think I, I mean you harm... All I ever wanted Was for you To know that I care