FW: Informix isql
Posted in 1999
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_000_01BE50CE.1A66B018
Content-Type: text/plain;
charset="iso-8859-1"
> hi,
>
> I am facing problem when uploading files into tables.
> Sometimes the batch files run smoothly and sometime not .( with the
> exactly same set of txt file to be uploaded)
> <<DroCreLoa.sh>>
> There is no problem for dropping table and creating table. Problem only
> arise for loading table. The below errors are more likely to arise when I
> run it at the background than doing it sequentialy.
>
> May I know the solution for this? Is the dbspace or log space a
> possible cause?
> Your help is greatly appreciated.
>
> regards,
> hylee
>
> ################### Below are err in upload##########
>
> awmso_pivload.sql.log: 255: Not in transaction.
>
> awmso_pivload.sql.log: 847: Error in load file line 36275.
>
> awmso_plnload.sql.log: 255: Not in transaction.
>
> awmso_plnload.sql.log: 847: Error in load file line 111860.
>
> awmso_plnul.sql.log: 244: Could not do a physical-order
> read to fetch next row.
>
>
> awmso_poaload.sql.log: 255: Not in transaction.
>
> awmso_poaload.sql.log: 847: Error in load file line 62751.
>
> awmso_pocload.sql.log: 255: Not in transaction.
>
> awmso_pocload.sql.log: 847: Error in load file line 27857.
>
> awmso_poeload.sql.log: 255: Not in transaction.
>
> awmso_poeload.sql.log: 847: Error in load file line 82931.
>
> awmso_polload.sql.log: 255: Not in transaction.
>
> awmso_polload.sql.log: 847: Error in load file line 52022.
>
> awmso_polul.sql.log: 244: Could not do a physical-order
> read to fetch next row.
>
>
> awmso_posload.sql.log: 255: Not in transaction.
>
> awmso_posload.sql.log: 847: Error in load file line 56227.
>
>
> -806 Cannot open file for unload.
>
>
>
> The output file that is specified in this UNLOAD statement
> could not be
> opened. Check the accompanying ISAM error code for more
> information.
> Possibly a more complete pathname is needed; the file
> exists, but your
> account does not have write permission for it; or the disk
> is full.
>
>
>
> -255 Not in transaction.
>
>
>
> The database server cannot execute this COMMIT WORK or
> ROLLBACK WORK
> statement because no BEGIN WORK was executed to start a
> transaction.
> Because no transaction was started, you cannot end one. Any
> database
> modifications that were made are now permanent; they cannot
> be rolled
> back but do not need to be committed. Review the sequence of
> SQL
> statements to see where the transaction should have started.
>
>
>
> This error can occur when you open a cursor for update and
> have not started
> a transaction yet.
>
>
> -244 Could not do a physical-order read to fetch next
> row.
>
>
> The database server cannot read the disk page that contains
> a row of a
> table. Check the accompanying ISAM error code for more
> information. A
> hardware problem might exist, or the table or index file
> might have
> been corrupted. Unless the ISAM error code or an
> operating-system
> message points to another cause, run the bcheck or secheck
> utility to
> verify file integrity.
>
>
>
------_=_NextPart_000_01BE50CE.1A66B018
Content-Type: application/octet-stream;
name="DroCreLoa.sh"
Content-Disposition: attachment;
filename="DroCreLoa.sh"
Content-Location: ATT-0-A47CBF4BBEBCD2119A1800805F8B809A-
#hylee 5/1/99
WORKDIR='/mis/p1/exec/app1/SYSTEM/WMS/Y2K'
rm $WORKDIR/OUT/*
#drop table
out='DROP'
for file in $(ls $WORKDIR/$out)
do
echo $file >$WORKDIR/OUT/$file.log
isql infimacs $WORKDIR/$out/$file >>$WORKDIR/OUT/$file.log 2>>$WORKDIR/OUT/$file.log &
done
wait
#create table
out='SCHEMA'
for file in $(ls $WORKDIR/$out)
do
echo $file >$WORKDIR/OUT/$file.log
isql infimacs $WORKDIR/$out/$file >>$WORKDIR/OUT/$file.log 2>>$WORKDIR/OUT/$file.log &
done
wait
#load table
DBDATE=y4md/export DBDATE
out='LOAD'
for file in $(ls $WORKDIR/$out)
do
cd $WORKDIR/DATA
echo $file >$WORKDIR/OUT/$file.log
isql infimacs $WORKDIR/$out/$file >>$WORKDIR/OUT/$file.log 2>>$WORKDIR/OUT/$file.log &
done
------_=_NextPart_000_01BE50CE.1A66B018--