Starting Connection Manager fails
Posted in 2017
Topics: Clustering, Grid & MACH11
after doing all the configuration settings for Connection Manager, while initialising the connection Manager as a service using the below command: oncmsm -i -c configuration_file. I have tried using the path also: oncmsm -i -c D:\\\\informixCSDK\\\\etc\\\\cmsm.cfg. Error: Error open Service Control Manager OS Error: Access is denied. The user is having administrator priviliges. My environment for connection Manager: OS : Windows 7 Separate machine for CM. Could anyone help me on this
This issue is solved.
Need to run the oncmsm as administrator command promt.
But getting another issue.
after starting the connection manager with below command
------> oncmsm cm_hdr
output:
Tue Jul 25 11:06:16 2017
11:06:16 Connection Manager Service "cm_hdr" started.
--------------------------------------------------------------------------------
----------------------------
Checking the log file of connection manager. it contains
Tue Jul 25 11:06:16 2017
11:21:51 IBM Informix Connection Manager
11:21:51 IBM Informix CSDK Version 4.10, IBM Informix-ESQL Version 4.10.FC6
11:21:51 Build Number: N246
11:21:51 Build Host: STARK
11:21:51 Build OS: Windows_NT 6
11:21:51 Build Date: Thu Oct 29 05:15:45 CDT 2015
11:21:51 GLS Version: glslib-6.00.FC7
11:21:51
11:21:51 SLA oltp listener mode REDIRECT
11:21:51 SLA report listener mode REDIRECT
11:21:51 Connection Manager name is cm_hdr
11:21:51 Starting Connection Manager...
11:21:52 Get server dbservers information failed, Connection Manager stopped
11:21:52 Error in cmsm_run() - Connection Manager service "cm_hdr"
11:21:52 OS Error: The operation completed successfully.
--------------------------------------------------------------------------------
---------------------------------
My configuration file cmsm.cfg consists of:
--------------------------------------------------------------------------------
-
NAME cm_hdr
LOG 1
LOGFILE D:\\\\informixCSDK\\\\tmp\\\\cm1.log
CLUSTER hdr_cluster
{
INFORMIXSERVER dbservers
SLA oltp DBSERVERS=PRI,HDR
SLA report DBSERVERS=HDR,PRI
FOC ORDER=HDR \\\\
PRIORITY=1
CMALARMPROGRAM D:\\\\informixCSDK\\\\etc\\\\cmalarmprogram.bat
}
--------------------------------------------------------------------------------
-------
Connection Manager sqlhost file contains:
#dbservername nettype hostname servicename options
dbserv_g group i=10,e=secondary
ol_informix1210 onsoctcp 199.166.155.195 ol_informix1210 g=dbservers
secondary onsoctcp 199.166.155.196 secondaryport g=dbservers
oltp onsoctcp 199.166.155.74 cm_port1
report onsoctcp 199.166.155.74 cm_port2
--------------------------------------------------------------------------------
-----------------------------------
What is the solution for this?
Change INFORMIXSERVER in the CM configuration file (cmsm.cfg) from
"dbservers" to "dbserv_g" the group defining the two actual servers.
Art
Art S. Kagel, President and Principal Consultant
ASK Database Management
www.askdbmgt.com
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on the IIUG, nor any other organization with which I am
associated either explicitly, implicitly, or by inference. Neither do
those opinions reflect those of other individuals affiliated with any
entity with which I am affiliated nor those of the entities themselves.
On Tue, Jul 25, 2017 at 1:54 AM, MUKESH TANUKU <mukeshbt1328@gmail.com>
wrote:
> This issue is solved.
> Need to run the oncmsm as administrator command promt.
>
> But getting another issue.
> after starting the connection manager with below command
> ------> oncmsm cm_hdr
>
> output:
> Tue Jul 25 11:06:16 2017
> 11:06:16 Connection Manager Service "cm_hdr" started.
>
>
> ------------------------------------------------------------
> ------------------------------------------------
> Checking the log file of connection manager. it contains
>
> Tue Jul 25 11:06:16 2017
> 11:21:51 IBM Informix Connection Manager
> 11:21:51 IBM Informix CSDK Version 4.10, IBM Informix-ESQL Version 4.10.FC6
> 11:21:51 Build Number: N246
> 11:21:51 Build Host: STARK
> 11:21:51 Build OS: Windows_NT 6
> 11:21:51 Build Date: Thu Oct 29 05:15:45 CDT 2015
> 11:21:51 GLS Version: glslib-6.00.FC7
> 11:21:51
> 11:21:51 SLA oltp listener mode REDIRECT
> 11:21:51 SLA report listener mode REDIRECT
> 11:21:51 Connection Manager name is cm_hdr
> 11:21:51 Starting Connection Manager...
> 11:21:52 Get server dbservers information failed, Connection Manager
> stopped
> 11:21:52 Error in cmsm_run() - Connection Manager service "cm_hdr"
> 11:21:52 OS Error: The operation completed successfully.
>
> ------------------------------------------------------------
> -----------------------------------------------------
>
> My configuration file cmsm.cfg consists of:
>
> ------------------------------------------------------------
> ---------------------
> NAME cm_hdr
> LOG 1
> LOGFILE D:\\\\informixCSDK\\\\tmp\\\\cm1.log
> CLUSTER hdr_cluster
> {
> INFORMIXSERVER dbservers
> SLA oltp DBSERVERS=PRI,HDR
> SLA report DBSERVERS=HDR,PRI
> FOC ORDER=HDR \\\\
>
> PRIORITY=1
> CMALARMPROGRAM D:\\\\informixCSDK\\\\etc\\\\cmalarmprogram.bat
> }
>
>
> ------------------------------------------------------------
> ---------------------------
>
> Connection Manager sqlhost file contains:
>
> #dbservername nettype hostname servicename options
> dbserv_g group i=10,e=secondary
> ol_informix1210 onsoctcp 199.166.155.195 ol_informix1210 g=dbservers
> secondary onsoctcp 199.166.155.196 secondaryport g=dbservers
>
> oltp onsoctcp 199.166.155.74 cm_port1
> report onsoctcp 199.166.155.74 cm_port2>
> ------------------------------------------------------------
> -------------------------------------------------------
>
> What is the solution for this?
>
>
> ************************************************************
> *******************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
I am sorry Mr.Art, by mistake i have mentioned dbservers actually i changed it to dbserv_g. Now the actual problem raises.