INTERVAL FUNCTION
Posted in 2003
tomL — — source: Usenet: comp.databases.informix
Hello,
I am unsure of why this function behaves like it does (or more
accurately, what the sql means)?
create_date is a DATETIME YEAR TO SECOND
select * from request wherecreate_date <= EXTEND(current, year to second) - interval (99) second
to second
why does the above statement work but when i replace 99 with 100, it
fails?
as i increase the number of seconds in the interval, i am required to
change the sql to this:
select * from request where
create_date <= EXTEND(current, year to second) - interval (18000)second (5) to second
what does the (5) mean and why do i have to increase it as i increase
the interval seconds? the above sql will fail if it is a (4) instead
of a (5).
Thanks in advance,
Tom