OnLine, ESQL/C and NIS
Posted in 1993
We are running the Network Information Service, a.k.a. Yellow Page, therefore the local /etc/passwd file on the machine that runs the OnLine engine does not have a record for me. I can still execute isql and other interactive utilities, but my ESQL/C process would die with an error number 468: "-468 Cannot obtain user id from system: unable to start database server. Your application is trying to open communications to a database server. As part of doing this it has to read your user id from the system password file, and it failed to do this. Look for operating system error messages that may give more specific information. Consult with a system administrator to make sure the file of user ids is readable to all users." Is there any way to integrate NIS with OnLine, so OnLine will also recognize user ids supplied by NIS? Thanks in advance for your response. With Regards, Pei-yu Huang