Re: Restoring database using logs
Posted in 1992
Hi there, In article <9158@emory.mathcs.emory.edu> rogerp@amgen.com (Roger Parks) writes: > > In <X-Informix-List-Id: <news.1505> > Mark Herbert describes a disaster: .. some lines deleted ... > > cannot restore the database because of the error. Informix here says > > they can't help, that there is nothing we can do. > > > > I find it hard to believe that the applications worked for the last week > > but now Informix says it is all lost. > > > > Can someone verify that indeed it is not possible to get the information > > in the log files back when an error in the database has occurred? If > > it is possible, can someone give us some advise on what to do? First I would recommend that you should call the Informix Tech Support group at Informix Munich (phone: +49-89-96098-215). I tried to track your case down... ..BUT it seems to be that you or you company never called the hotline phone number mentioned above! (We do have a caselog system which logs EVERY customer problem...) Otherwise you should have been in contact with one of our Advanced Support engineers who are able to login to your system and do (nearly) the same things like our colleagues in Menlo Park (as described by Roger below...). .. some lines deleted ... > The best response I can give you is to suggest that you 'phone Informix Customer Service in Menlo Park. Assuming that your system will permit it, > they can dial your system up and then reproduce your logs up to the point > of the recorded write failure. The problem is that the backup will only > be good up to the point in time of the problem being detected in the log. > At issue is the question of how much this will save you. If the logs > can be edited, and no data integrity problems are found, then it might > be possible for the log file to be edited and permit more of the log > to be entered into the database. Only you can answer that one. .. some additional lines deleted ... In order to help to avoid this kind of problems in the future, I would recommend to set up a small shell script, which scans periodically your online.log file for any kind of error message and send this messages to some responsible persons in your company via email. Such a script could be run automatically as a cron job. Just to let you know that there is also an Informix Tech Support group in Germany, who is listening to the net... :-) :-) Greetings from Munich, Alexander Koerner Advanced Support Group -- Alexander Koerner @ Informix Germany Oskar-Messter-Str. 25, D-8045 Ismaning Tel.: +49 89 960 98 215 Fax: +49 89 960 98 500 UUCP: ...!{pyramid,uunet}!infmx!infmuc!alexk