Can't connect to database - Unknown error message 84
Posted in 2009
Topics: Connectivity: ODBC / JDBC / .NET, Security, Permissions & Auditing, Platform-Specific Issues, Internationalization & Character Sets, Versions, Editions & End-of-Life
Dear Informixers,
we are running IDS 10.00.UC6 on SLES10 SP1. The server gets most
users via NIS from Active Directory, this setup has been running without
problems for over a year.
AD users must change their passwords every 3 months per company policy.
NIS propagates these password changes to the Linux machines. None of these
password changes in the past have caused any troubles.
After changing my password last week, I cannot connect to IDS any more.
I get the following error message:
952: User (xxx)'s password is not correct for the database server.
Unknown error message 84.
I can login to the server with the new password just fine, it's just
the database connection that is not working. Strangely, all my ODBC and
JDBC connections configured on various Windows clients that have the old
password stored do still work! But as soon as I touch any one of them and
change the stored password to the new one, they fail with the above error.
Moreover, after that they don't even work when I try the old password again.
My password's don't contain any irregular characters, only letters and
numbers, so I can exclude any character set problems.
Any idea about the cause, and a solution?
Regards, Richard
Unless IDS is caching the authentication, which it shouldn't. You should be fine.
IDS is going to authenticate against either the system or against whatever you specified in the $INFORMIXDIR/etc/sqlhosts table.
Based on what you said, your old password still works so that I'd have to say that not all of your caches were updated when you changed your password.
Does that make sense?
> From: Richard.Spitz@med.uni-muenchen.de
> Subject: Can't connect to database - Unknown error message 84
> Date: Wed, 29 Apr 2009 17:49:50 +0200
> To: informix-list@iiug.org
>
> Dear Informixers,
>
> we are running IDS 10.00.UC6 on SLES10 SP1. The server gets most
> users via NIS from Active Directory, this setup has been running without
> problems for over a year.
>
> AD users must change their passwords every 3 months per company policy.
> NIS propagates these password changes to the Linux machines. None of these
> password changes in the past have caused any troubles.
>
> After changing my password last week, I cannot connect to IDS any more.
> I get the following error message:
>
> 952: User (xxx)'s password is not correct for the database server.
> Unknown error message 84.>
> I can login to the server with the new password just fine, it's just
> the database connection that is not working. Strangely, all my ODBC and
> JDBC connections configured on various Windows clients that have the old
> password stored do still work! But as soon as I touch any one of them and
> change the stored password to the new one, they fail with the above error.
> Moreover, after that they don't even work when I try the old password again.
> My password's don't contain any irregular characters, only letters and
> numbers, so I can exclude any character set problems.
>
> Any idea about the cause, and a solution?
>
> Regards, Richard
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
_________________________________________________________________
Windows Live™ SkyDrive™: Get 25 GB of free online storage.
http://windowslive.com/online/skydrive?ocid=TXT_TAGLM_WL_skydrive_042009
Richard Spitz wrote:
> Dear Informixers,
>
> we are running IDS 10.00.UC6 on SLES10 SP1. The server gets most
> users via NIS from Active Directory, this setup has been running without
> problems for over a year.
>
> AD users must change their passwords every 3 months per company policy.
> NIS propagates these password changes to the Linux machines. None of these
> password changes in the past have caused any troubles.
>
> After changing my password last week, I cannot connect to IDS any more.
> I get the following error message:
>
> 952: User (xxx)'s password is not correct for the database server.
> Unknown error message 84.>
> I can login to the server with the new password just fine, it's just
> the database connection that is not working. Strangely, all my ODBC and
> JDBC connections configured on various Windows clients that have the old
> password stored do still work! But as soon as I touch any one of them and
> change the stored password to the new one, they fail with the above error.
> Moreover, after that they don't even work when I try the old password again.
> My password's don't contain any irregular characters, only letters and
> numbers, so I can exclude any character set problems.
>
> Any idea about the cause, and a solution?
>
> Regards, Richard
>
Did you change the password encryption algorithm?
This looks familiar to situations where this have happened...
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...