Informix on Red Hat 6
Posted in 2008
Topics: Installation, Setup & Upgrades, Stored Procedures & SPL, Platform-Specific Issues
Hello, I have a RedHat6 Server with Informix installed. There are 3 Client machines, that run a program, that uses the DB. Now I tried to change one client with a newer Linux machine (OpenSuse). The clients uses the program with Informix via NFS. The program starts, the menu appears, I can run some points that don't use Informix. As soon as I click on a button, which is evoking a frontend that is using Informix, it claims, that the database can't be opened. First I thought it is a permission problem, but I changed users and groups to match the old machine. Still no success. Please, I would appreciate, if someone can give me a hint, where I can find settings or still better the logs of informix. Somewhere the reason must be stated, but I can't find the file or location. The strange thing is, that it runs on the server and displays on the client. IMHO the server should determine the permissions? Sorry for inconvenience, best regards, Ernst Schmidtmann
virgincita schmidtmann wrote: > Hello, > > I have a RedHat6 Server with Informix installed. There are 3 Client > machines, that run a program, that uses the DB. > > Now I tried to change one client with a newer Linux machine (OpenSuse). The > clients uses the program with Informix via NFS. > > The program starts, the menu appears, I can run some points that don't use > Informix. As soon as I click on a button, which is evoking a frontend that > is using Informix, it claims, that the database can't be opened. > > First I thought it is a permission problem, but I changed users and groups > to match the old machine. Still no success. > > Please, I would appreciate, if someone can give me a hint, where I can find > settings or still better the logs of informix. Somewhere the reason must be > stated, but I can't find the file or location. > > The strange thing is, that it runs on the server and displays on the client. > IMHO the server should determine the permissions? > > Sorry for inconvenience, > > best regards, > > Ernst Schmidtmann > > When you try to connect to Informix and/or open a database you receive an error in case of failure... What message do you receive? Is it an Informix error or a costum message? Do you have the source code? Solving problems without error messages is difficult... -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently...
Just a thought. No match informix user id on newer Linux machine. machine_1 informix:999:999 machine_2 informix:999:999 machine_3 (newer Linux machine) informix:5000:5000 Then, newer Linix machine can not access file of onwer informix(999) Error messages are helping us. Regards. -- Tsutomu Ogiwara from Tokyo Japan. > From: domusonline@gmail.com> Subject: Re: Informix on Red Hat 6> Date: Mon, 25 Aug 2008 23:13:47 +0100> To: informix-list@iiug.org> > virgincita schmidtmann wrote:> > Hello,> > > > I have a RedHat6 Server with Informix installed. There are 3 Client > > machines, that run a program, that uses the DB.> > > > Now I tried to change one client with a newer Linux machine (OpenSuse). The > > clients uses the program with Informix via NFS.> > > > The program starts, the menu appears, I can run some points that don't use > > Informix. As soon as I click on a button, which is evoking a frontend that > > is using Informix, it claims, that the database can't be opened.> > > > First I thought it is a permission problem, but I changed users and groups > > to match the old machine. Still no success.> > > > Please, I would appreciate, if someone can give me a hint, where I can find > > settings or still better the logs of informix. Somewhere the reason must be > > stated, but I can't find the file or location.> > > > The strange thing is, that it runs on the server and displays on the client. > > IMHO the server should determine the permissions?> > > > Sorry for inconvenience,> > > > best regards,> > > > Ernst Schmidtmann > > > > > > When you try to connect to Informix and/or open a database you receive an error > in case of failure...> What message do you receive? Is it an Informix error or a costum message?> Do you have the source code?> > Solving problems without error messages is difficult...> > -- > Fernando Nunes> Portugal> > http://informix-technology.blogspot.com> My email works... but I don't check it frequently...> _______________________________________________> Informix-list mailing list> Informix-list@iiug.org> http://www.iiug.org/mailman/listinfo/informix-list _________________________________________________________________ 2008年8月 暑い夏を快適に過ごす裏ワザ。MSN相談箱で探してみよう! http://questionbox.jp.msn.com/search.php3?StatusCheck=ON&search_type=word&kw=%8F%8B%82%B3%91%CE%8D%F4
Hi, the IDS message log is on the machine where the IDS instance is running. In the environment of the IDS instance check for the environment variables $INFORMIXDIR and $ONCONFIG, then find the setting for parameter MSGPATH in the onconfig file (at $INFORMIXDIR/etc/$ONCONFIG). It may be a setup problem of the new machine (not being able to "find" the IDS instance), or (simply) an authorization problem. Without knowing how the 3 (older) client machines connect to the IDS instance it is difficult to tell what may be wrong with the new machine. Possibly you have the following situation?: The 3 (older) client machines connect as "trusted hosts" to the IDS instance. This usually is enabled via files like .rhosts or hosts.equiv on the machine where the IDS instance is running. The newer client machine does not have this "trusted host" status on the machine where the IDS instance is running. Therefore connection requests from the newer machine are rejected. Note: If it is an authorization problem, then it doesn't really matter that the binaries are on an NFS mounted file system, because the machine is different (IP address, hostname, etc.), Regards, Martin -- Martin Fuerderer IBM Informix Development Munich, Germany Information Management IBM Deutschland Research & Development GmbH Chairman of the Supervisory Board: Martin Jetter Board of Management: Erich Baier Corporate Seat: Boeblingen, Germany Reg.-Gericht: Amtsgericht Stuttgart, HRB 243294 informix-list-bounces@iiug.org wrote on 25.08.2008 23:39:54: > Hello, > > I have a RedHat6 Server with Informix installed. There are 3 Client > machines, that run a program, that uses the DB. > > Now I tried to change one client with a newer Linux machine (OpenSuse). The > clients uses the program with Informix via NFS. > > The program starts, the menu appears, I can run some points that don't use > Informix. As soon as I click on a button, which is evoking a frontend that > is using Informix, it claims, that the database can't be opened. > > First I thought it is a permission problem, but I changed users and groups > to match the old machine. Still no success. > > Please, I would appreciate, if someone can give me a hint, where I can find > settings or still better the logs of informix. Somewhere the reason must be > stated, but I can't find the file or location. > > The strange thing is, that it runs on the server and displays on the client. > IMHO the server should determine the permissions? > > Sorry for inconvenience, > > best regards, > > Ernst Schmidtmann > > > _______________________________________________ > Informix-list mailing list > Informix-list@iiug.org > http://www.iiug.org/mailman/listinfo/informix-list