Dbimport cannot create index? Help!
Posted in 2005
A dbimport on IDS 9.30 under Windows 2000 failed while building indexes with "cannot create index" / "no free disk space" errors even though the OS drive had gigabytes free. Responders explained the limit is Informix's own space allocation, not the filesystem: the dbspace/temp space must be large enough (temp space roughly the size of the table being indexed). The poster solved it by dropping and recreating the instance with more space, and was then told the non-destructive route is to add a chunk to the existing dbspace with the onspaces -a command (see onspaces -? or the manual for syntax).
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion
I am trying to import a database for exported text files of whole database. When it is trying to create an index, I get error messages like "Cannot create index" and "no free disk space". However, there are gb free on that drive. Does it have to do with how much space is allocated to the database? How do I increase that amount? Thaks -- Craig
Hi, To create an index, make sure that the temp space is as big as the table that you are creating the index from. Regards Diane -----Original Message----- From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On Behalf Of Mr Johnson Sent: Monday, March 28, 2005 7:37 AM To: ids@iiug.org Subject: Dbimport cannot create index? Help! [4616] I am trying to import a database for exported text files of whole database. When it is trying to create an index, I get error messages like "Cannot create index" and "no free disk space". However, there are gb free on that drive. Does it have to do with how much space is allocated to the database? How do I increase that amount? Thaks -- Craig
I ended up deleting the instance, and re-creating it with more space. Dbimport worked this time. How do I increase the db space without recreating the instance? (I am using IDS 9.30 on Windows 2000 server.) Thanks Craig > -----Original Message----- > From: Lavoie, Diane [mailto:diane.lavoie@domtar.com] > Sent: Monday, 28 March 2005 11:18 > To: Mr Johnson; ids@iiug.org > Subject: RE: Dbimport cannot create index? Help! [4616] > > > Hi, > To create an index, make sure that the temp space is as big > as the table > that you are creating the index from. > Regards > Diane > > -----Original Message----- > From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On > Behalf Of Mr Johnson > Sent: Monday, March 28, 2005 7:37 AM > To: ids@iiug.org > Subject: Dbimport cannot create index? Help! [4616] > > I am trying to import a database for exported text files of whole > database. When it is trying to create an index, I get error messages > like "Cannot create index" and "no free disk space". However, > there are > gb free on that drive. > > Does it have to do with how much space is allocated to the > database? How > do I increase that amount? > > Thaks > > -- > Craig
I think what
you're trying to do is add a chunk to an existing space (that
adds more disk space to the current dbspace).
In order to do that, you're going to use the onspaces command; onspaces -a
is the base of what you're trying for, but I can't remember the syntax past
that. If you do an onspaces -? on the command line, you'll get the syntax
for the command. It's pretty self-explanatory, but if you have questions,
you can either post back, or look in the manual (it's also pretty well
explained/documented there).
Good luck, and I hope you enjoy working with Informix.
Dan Michaelis
Database Administrator/Developer
eOriginal
351 West Camden Street
Suite 800
Baltimore, MD 21201
410.625.5187 (phone)
410.659.9799 (fax)
-----Original Message-----
From: Mr Johnson [mailto:CJohnson@wcc.qld.edu.au]
Sent: Monday, March 28, 2005 8:54 AM
To: ids@iiug.org
Subject: RE: Dbimport cannot create index? Help! [4618]
I ended up deleting the instance, and re-creating it with more space.
Dbimport worked this time.
How do I increase the db space without recreating the instance? (I am
using IDS 9.30 on Windows 2000 server.)
Thanks
Craig
> -----Original Message-----
> From: Lavoie, Diane [mailto:diane.lavoie@domtar.com]
> Sent: Monday, 28 March 2005 11:18
> To: Mr Johnson; ids@iiug.org
> Subject: RE: Dbimport cannot create index? Help! [4616]
>
>
> Hi,
> To create an index, make sure that the temp space is as big
> as the table
> that you are creating the index from.
> Regards
> Diane
>
> -----Original Message-----
> From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
> Behalf Of Mr Johnson
> Sent: Monday, March 28, 2005 7:37 AM
> To: ids@iiug.org
> Subject: Dbimport cannot create index? Help! [4616]
>
> I am trying to import a database for exported text files of whole
> database. When it is trying to create an index, I get error messages
> like "Cannot create index" and "no free disk space". However,
> there are
> gb free on that drive.
>
> Does it have to do with how much space is allocated to the
> database? How
> do I increase that amount?
>
> Thaks
>
> --
> Craig
Use onspaces
utility
-----Mensaje original-----
De: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] En
nombre de Mr Johnson
Enviado el: Lunes, 28 de Marzo de 2005 10:54 a.m.
Para: ids@iiug.org
Asunto: RE: Dbimport cannot create index? Help! [4618]
I ended up deleting the instance, and re-creating it with more space.
Dbimport worked this time.
How do I increase the db space without recreating the instance? (I am
using IDS 9.30 on Windows 2000 server.)
Thanks
Craig
> -----Original Message-----
> From: Lavoie, Diane [mailto:diane.lavoie@domtar.com]
> Sent: Monday, 28 March 2005 11:18
> To: Mr Johnson; ids@iiug.org
> Subject: RE: Dbimport cannot create index? Help! [4616]
>
>
> Hi,
> To create an index, make sure that the temp space is as big
> as the table
> that you are creating the index from.
> Regards
> Diane
>
> -----Original Message-----
> From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
> Behalf Of Mr Johnson
> Sent: Monday, March 28, 2005 7:37 AM
> To: ids@iiug.org
> Subject: Dbimport cannot create index? Help! [4616]
>
> I am trying to import a database for exported text files of whole
> database. When it is trying to create an index, I get error messages
> like "Cannot create index" and "no free disk space". However,
> there are
> gb free on that drive.
>
> Does it have to do with how much space is allocated to the
> database? How
> do I increase that amount?
>
> Thaks
>
> --
> Craig
AVISO LEGAL:
Esta informacion es privada y confidencial y esta dirigida unicamente a su
destinatario. Si usted no es el destinatario original de este mensaje y por
este medio pudo acceder a dicha informacion por favor elimine el mensaje. La
distribucion o copia de este mensaje esta estrictamente prohibida. Esta
comunicacion es solo para propositos de informacion y no debe ser considerada
como propuesta, aceptacion ni como una declaracion de voluntad oficial de
REPSOL YPF S.A. y/o subsidiarias y/o afiliadas. La transmision de e-mails no
garantiza que el correo electronico sea seguro o libre de error. Por
consiguiente, no manifestamos que esta informacion sea completa o precisa.
Toda informacion esta sujeta a alterarse sin previo aviso.
This information is private and confidential and intended for the recipient
only. If you are not the intended recipient of this message you are hereby
notified that any review, dissemination, distribution or copying of this
message is strictly prohibited. This communication is for information purposes
only and shall not be regarded neither as a proposal, acceptance nor as a
statement of will or official statement from REPSOL YPF S.A. and/or
subsidiaries and/or affiliates. Email transmission cannot be guaranteed to be
secure or error-free. Therefore, we do not represent that this information is
complete or accurate and it should not be relied upon as such. All information
is subject to change without notice.
Mr Johnson said: > I am trying to import a database for exported text files of whole > database. When it is trying to create an index, I get error messages > like "Cannot create index" and "no free disk space". However, there are > gb free on that drive. > > Does it have to do with how much space is allocated to the database? How > do I increase that amount? It's all in the manual! ;o) -- Bye now, Obnoxio "C'est pas parce qu'on n'a rien à dire qu'il faut fermer sa gueule" - Coluche "I'm trying to see things your way, but I can't get my head up my ass" - JCH "Ogni uomo mi guarda come se fossi una testa di cazzo" - Marco Travel broadens a person. You look as if you have been all over the world. I went to the airport to check in and they asked what I did because I looked like a terrorist. I said I was a comedian. They said, "Say something funny then." I told them I had just graduated from flying school. -- Ahmed Ahmed http://i2.photobucket.com/albums/y41/Obnoxio/thinkIfoundtheproblem.jpg
Thanks for all the help and replies.. I'm now out of my dilemma! Craig. > -----Original Message----- > From: forum.subscriber@iiug.org > [mailto:forum.subscriber@iiug.org] On Behalf Of Mr Johnson > Sent: Monday, 28 March 2005 11:54 > To: ids@iiug.org > Subject: RE: Dbimport cannot create index? Help! [4618] > > > I ended up deleting the instance, and re-creating it with more space. > Dbimport worked this time. > > How do I increase the db space without recreating the instance? (I am > using IDS 9.30 on Windows 2000 server.) > > Thanks > > Craig