DB Administrator wrote:
>
> Hi!
[SNIP]
> First, how many errors are below? Two, four or one? There isn't any error
> number.
> In the Administrators Guide, there is written, that when I have "down chunk"
> which doesn't contains logical logs and ... "database server can continue to
> operate, but cannot write to or read from the down chunk or any other chunks
> in the dbspace of that chunk." But the situation is that I have a result for
> the query, which data are in this chunk. I found the tables in the chunk
> using "oncheck -pe". So, my "SELECT" returns me results without any errors,
> hence I can read from this chunk. In my "online.log" there isn't anything
> related that chunk is down, when I "oninit" Informix. Only "oninit" reports,
> that the chunk is down on the standard output when I initialize Informix.
> Is the only what I can do is to do a dbspace restore from the backup
> archive? The data in this dbspace aren't critical and doesn't depend from
> other data.
> Does my unloaded data are correct? (UNLOAD TO ... SELECT * FROM
> table_in_down_chunk)
Does onstat -d report the chunk and/or dbspace down (flags PD instead
of PO)? If so probably the only option is to restore assuming you have
up-to-date logs and know that the archive was taken before the
corruption took place. Otherwise, ask tech support to mark things back
online, unload as much data as possible from affected tables in the
dbspace, drop and recreate the dbspace (ignore the warnings about
having to perform an archive before you can readd the chunks since you
will be adding the same dbspace and chunks anyway, and will hopefully
take and archive immediately after this is over), recreate the tables,
reload the data, repair any missing data as well as you can.
After you catch your breath find out from tech support if there is a
known bug on your platform/version that might have caused the
corruption and upgrade accordingly if possible.
Art S. Kagel