Hi,
I got an error "-25572 Network driver cannot bind a name to the port" when I
run the following 4gl:
MAIN
database stores7@testtcp --connect to stores7 via tcp/ip
END MAIN
Some related configurations are:
INFORMIXSER=test
ONCONFIG=onconfig.testuname -a -> sun440
under $INFORMIXSQLHOSTS:
test onipcshm sun440 test
testtcp ontlitcp sun440 testtcp
in etc/services
..
testtcp 8666/tcp
in $INFORMIXDIR/etc/onconfig.test
DBSERVERNAME test # Name of default database server
DBSERVERALIASES testtcp
NETTYPE ipcshm,1,10,CPU
NETTYPE tlitcp,1,10,NET
The interesting thing is I can run "dbaccess stores7@testtcp" with no error,
and
If I change 2nd line in above 4gl to "database stores7@test",the 4gl runs fine.
Can somebody give any suggestion?
Thanks in advance,
Gary
↪ replying to GARY GU
forum.subscriber@iiug.org wrote on 05/24/2004
04:58:43 PM:
> I got an error "-25572 Network driver cannot bind a name to the
> port" when I run the following 4gl:
>
> MAIN
> database stores7@testtcp --connect to stores7 via tcp/ip
> END MAIN
>
> Some related configurations are:
>
> INFORMIXSER=test
> ONCONFIG=onconfig.test> uname -a -> sun440
>
> under $INFORMIXSQLHOSTS:
> test onipcshm sun440 test
> testtcp ontlitcp sun440 testtcp>
> in etc/services
> testtcp 8666/tcp
>
> in $INFORMIXDIR/etc/onconfig.test
> DBSERVERNAME test # Name of default database server
> DBSERVERALIASES testtcp
> NETTYPE ipcshm,1,10,CPU
> NETTYPE tlitcp,1,10,NET>
> The interesting thing is I can run "dbaccess stores7@testtcp" with
> no error, and
> If I change 2nd line in above 4gl to "database stores7@test", the
4glruns fine.
>
> Can somebody give any suggestion?
Some version information might help. For example, it appears that you are
probably on a Sun, presumably running Solaris rather than SunOS, but which
version? Which version of IDS? Which version of I4GL?
ONCONFIG is not needed in the environment - that's used by the IDS
administration utilities, not by client programs such as I4GL.
INFORMIXSER is not an Informix environment variable; I assume you meant
INFORMIXSERVER.
That DB-Access is working and I4GL is not makes me wonder whether you've
got an archaic version of I4GL - there used to be some weird problems in
the area of connectivity, hence my questions.
--
Jonathan Leffler (jleffler@us.ibm.com)
STSM, Informix Database Engineering, IBM Data Management
4100 Bohannon Drive, Menlo Park, CA 94025
Tel: +1 650-926-6921 Tie-Line: 630-6921
"I don't suffer from insanity; I enjoy every minute of it!"