Re: RDS 4.14/SE 5.06 Error dropping TEMP tables
Posted in 1996
I had problems with dropping a temp table, the workaround is to delete all data from your table for each cycle of use. Mariusz Malogrosz mariuszm@tecsys.com Computec Systems Support Ltd (158.152.33.120) wrote: : Hi Informixers, : Can anybody please help me with this problem: : We have just upgraded our Informix RDS from v4.10 to v4.14, SE from v4.00 : to v5.06 and SCO Unix from 3.2.2 to sco Openserver Enterprise v5.0 : I have several programs which use the SELECT ..... INTO TEMP tmp_table : syntax. Before selecting records into the temp table I issue the : DROP TABLE tmp_table command to ensure that the table does not already : exist as the select statement is run several times during program : execution. : On our old system this worked ok, but on the new system, if the temp : table has already been created by the SELECT statement, the DROP command : returns the following error: : SQL Error: -242, ISAM Error: -106 : Could not open database table (tmp_table) : The subsequent SELECT ... INTO TEMP tmp_table then gives error: : SQL Error: -310, SQL Error: 0 : Table (tmp_table) already exists in database : I have checked the Unix file permissions and the user has full access to : the full pathname of the files. : Has anybody experienced similar problems or can you offer any help ? : Suggestions will be gratefully received, : Regards, : Keith. : compsys.demon.co.uk