Re: Dbaccess Error : 25572: Network driver cannot bind a name to the port.
Posted in 2004
Sudhir,
Try using a different port in the /etc/services file:
services file
######################################
# on_test_3 1545/tcp
on_test_3 1546/tcp
If this works, then port 1545 is probably unusable until the next
reboot. A reboot frees all bound ports; There is probably another way
of doing this without a reboot, but I'm not that good of a systems
administrator.
You can use isql, i4gl, and esqlc to run sql queries instead of
dbaccess. I believe that some other 3rd-party products also allow sql
queries to run against the instance.
Hope this information helps.
Brice Avila
Minneapolis, Minnesota
Sudhir Sambrani <sudhirsambrani@gmail.com> wrote in message news:<cbpe7v$pmo$1@news.xmission.com>...
> Hi All
>
> I am using IDS 9.2 on a solaris box
>
> I get this error when i use dbaccess
>
> 25572: Network driver cannot bind a name to the port.>
> anybody know why i am getting this error
>
> the entries in my sqlhosts file seem ok
>
> sqlhosts file
> #####################################
> test_3 ontlitcp test_3 on_test_3>
>
> services file
> ######################################
> on_test_3 1545/tcp
>
>
> hosts file
> ######################################
> ip_address hostname test_3 loghost
>
>
> is there any other utility other than dbaccess
> where we cud run queries
>
>
>
> Thanks
> Sudhir
> sending to informix-list