Re: INFORMIX-4GL 4.0 upgrade problem - reserved words/column names
Posted in 1991
Will Johnson writes in X-Informix-List-Id: <list.284> >I am in the process of converting a client's INFORMIX-4GL application >from the INFORMIX 2.10 level to release 4. I have encountered a >problem with programs that have been working for 4 years, but now >fail with SQL -201 errors (SQL syntax) on UPDATE statements. After much >head scratching I decided to review the reserved words list against >the column names in the tables. I found that I had long ago created >this table with a column named length, which also is a reserved word. >This did not bother the previous versions of INFORMIX-4GL, but the >4.0 SE engine is another matter. If you look in the appendices of your Informix manuals there is a section on administartion tables created for each database. All of these tables begin sys (Eg. systables, syscolumns, etc). These tables contain all the setup information for each database and are actual Informix tables themselves. This means that the above problem can be solved very simply. Create forms for each of these tables and wherever the word 'length' is used in a colname field change it to media_length. Alternatively use a SQL update statement for the appropriate tables. Eg UPDATE syscolumns SET colname = "media_length" WHERE colname = "length" Hope this helps, Jim -------------------------------------------------------------------- Name: Jim Gordon Internet: jgordon@ssf-sys.DHL.COM Company: DHL Systems Inc Phone: (415) 358-5911 Address: 1700 S. Amphlett Blvd. Fax: (415) 571-6429 San Mateo, CA 94402 --------------------------------------------------------------------