Re: What does "oninit -v" do?
Posted in 1998
>I accidentally typed "onint -v" while the engine was already up and
>logged in as informix. I received this message in
>$INFORMIDIR/online.log:
>
>21:34:51 shmget: [EEXIST][17]: key 52564801: shared memory already>exists
>21:34:51 mt_shm_init: can't create resident segment>
>If it applies, can I undo what this command did?
>
>I am running OnLine 7.22.UC2.
>
>Thanks.
>
>Edwin Babadaglian
Rest easy - The oninit -v did no harm and was not the cause of the error that
you got.
The "-v" option is used to display messages that tells what the engine is doing
when it is being brought up. It is used to aid when the engine will not come
up correctly and we don't know what it was doing when the initialization
failed.
The error that you got indicates that the shared memory for the engine was
already allocated. Basically that you were trying to start a second occurance
of the same Informix instance.
Madison Pruet