Cannot Attach to Transaction
Posted in 2003
I am using the ODBC connection to
attach to a 5.x database... It works on all of my other servers from AIX to
Windows 2000... But on one Informix 5.x server I get the following error when
I try to test the connection to Informix 5.x Server Using ODBC...
Cannot Attach to Transaction
Here is the rest of the information associated with the error...
### ON THE WINDOWS 2000 MACHINE DBPING RETURNS THE FOLLOWING:
SQLAllocEnv Successful
SQLAllocConnect Successful
There was an error within SQLConnect!
SQLState = S1000
Native Error = -529
Error Message = [Informix][Informix ODBC Driver][Informix]Cannot attach to
transaction.
### NATIVE ERROR RETURNS THE FOLLOWING INFORMATION ON SERVER
admin:/sw/informix: finderr -529
-529 Cannot attach to shared memory.
This error message appears prior to Version 6.0. Your application
program is unable to initialize its connection to the database server
because you are using a shared-memory implementation. Either the
database shared memory has not been initialized, or the maximum number
of users has already started using the system. Check the accompanying
ISAM error code for more information.
-529 Cannot attach to transaction.
This error message appears beginning with Version 6.0. Your application
program is unable to initialize its connection to the database server
because you are using a shared-memory implementation. Either the
database shared memory has not been initialized, or the maximum number
of users has already started using the system. Check the accompanying
ISAM error code for more information.
### DEVELOPEMENT DOCUMENTATION ERROR INFORMATION BELOW...
SQLSTATE S1000 (General error)
An Informix ODBC Driver SQLSTATE value, which ranges from
S1000 to S19ZZ.
For example, SQLSTATE S1001 (Memory-allocation failure) indicates
that the call from the driver manager to the driver-level
SQLAllocEnv returned SQL_ERROR, and the henv from the driver
manager was set to SQL_NULL_HENV.
SQLSTATE Error Message Can be returned from
01000 General warning All Informix ODBC Driver
functions except:
SQLAllocEnv
SQLError