Re: tbcheck problems HP9000 G30
Posted in 1994
In article 6BE@netcom.com, jlumbley@netcom.com (Joe Lumbley) writes: >Has anyone else seen any problems with tbcheck -cr on a HP 9000 G30 with >OnLine 5.02? Every time I run it, it dies on the physical logs with a >I/O Error, bad chunk at the first page of the physical log. I've tried >moving the physlogs to another dbspace and greatly reducing the size,but >the problem follows the logs and gives the same error with the correct >page & chunk info for the first page of the new physlogs. > >Tbcheck -pP chunk page reads it out without obvious errors, all logging >activities seem ok, physical log reads and writes are no problem. When I >run the tbcheck -cr (or -pr) , I get an error message in online.log, but >no other indications of errors unless from tbcheck. So far it looks like >strictly a problem with tbcheck...... > >Informix is working on it, but says they can't duplicate it (do I detect >a pattern here? :v( ) > >Any similar cases and/or solutions would be helpful. Joe, It is because the physical log is not located in the root dbspace. It is a known problem, and can be duplicated by creating an OnLine instance and moving the physical log to another (non-root) dbspace. Move the physical log to the root dbspace, and your tbcheck -[cp]r will work. If your physical log is in your root dbspace, then I don't know what the cause of the problem is. Bill Glidden glidden@informix.com