=?ISO-8859-1?Q?Can=B4t_recreate_index_on_temp_tab?= =?ISO-8859-1?Q?le_if_table_vanishes_by_rollback?=
Posted in 2005
Topics: Error Codes & Troubleshooting, Clustering, Grid & MACH11
We're running Informix Dynamic Server 9.40.FC3 on a HP alpha cluster
node. One of our applications is creating temp table's with indexes
within a transaction. When the transaction is rolled back, the temp
tables are gone. However if the application tries to recreate the temp
tables and indexes in the same session, creating the indexes always
fails with:
SQL statement error number -242.
Could not open database table (12spilk.t_tmp_fasumme)
SYSTEM error number -106.
ISAM error: non-exclusive access.
How can i avoid this problem?
If you use "CREATE TEMP TABLE tabname ... WITH NO LOG" or "SELECT ... INTO TEMP
tabname WITH NO LOG", it should still be there after the rollback to keep or
explicitly drop as desired.
--
Regards,
Doug Lawry
www.douglawry.webhop.org
"J?rg Spilker" <js@jetsys.de> wrote in message
news:4841fce4.0501250433.253f770e@posting.google.com...
> We're running Informix Dynamic Server 9.40.FC3 on a HP alpha cluster
> node. One of our applications is creating temp table's with indexes
> within a transaction. When the transaction is rolled back, the temp
> tables are gone. However if the application tries to recreate the temp
> tables and indexes in the same session, creating the indexes always
> fails with:
>
> SQL statement error number -242.
> Could not open database table (12spilk.t_tmp_fasumme)
> SYSTEM error number -106.
> ISAM error: non-exclusive access.>
> How can i avoid this problem?