"onaudit -l 1" not working
Posted in 2011
Topics: Security, Permissions & Auditing, Platform-Specific Issues
Hi, I'm in a bit of a rush (last minute urgent request from management).
We are running:
IBM Informix Dynamic Server Version 10.00.FC8XF
on AIX 5
We have auditing enabled on Production, and this gets restored to a DR
server (where auditing is not enabled). I am trying to enable it, but get
the error:
/audit/auditing # onaudit -l 1
Onaudit -- Audit Subsystem Configuration Utility
Copyright IBM Corporation 1996, 2004 All rights reserved.
Cannot set audit configuration parameters.
Problem may be caused by lack of permission, bad
parameter values, or bad parameter combinations.
I haven't worked with onaudit before - any quick tips ? I compared the
file permissions between the production and the DR server, and they are
the same. So I am assuming this is something else ?
Management didn't give me enough time to RTFM, my apologies.
Dirk
On Thu, Apr 21, 2011 at 08:38, Dc Dirk Moolman <DIRK@za.ibm.com> wrote:
> Hi, I'm in a bit of a rush (last minute urgent request from management).
>
> We are running:
> IBM Informix Dynamic Server Version 10.00.FC8XF on AIX 5
>
> We have auditing enabled on Production, and this gets restored to a DR
> server (where auditing is not enabled). I am trying to enable it, but get
> the error:
>
> /audit/auditing # onaudit -l 1
> Onaudit -- Audit Subsystem Configuration Utility
> Copyright IBM Corporation 1996, 2004 All rights reserved.
>
> Cannot set audit configuration parameters.
> Problem may be caused by lack of permission, bad
> parameter values, or bad parameter combinations.
>
>
The '#' in the prompt suggests you are working as root. Don't. Work as
informix.
If you have role-separation enabled, then the discussion gets more complex.
> I haven't worked with onaudit before - any quick tips ? I compared the
> file permissions between the production and the DR server, and they are
> the same. So I am assuming this is something else ?
>
> Management didn't give me enough time to RTFM, my apologies.
>
--
Jonathan Leffler <jonathan.leffler@gmail.com> #include <disclaimer.h>
Guardian of DBD::Informix - v2008.0513 - http://dbi.perl.org
"Blessed are we who can laugh at ourselves, for we shall never cease to be
amused."
--90e6ba6e89c60dd14704a17163f0
onaudit has a bad tendency to raise cryptic errors.
Things to try:
onaudit -l 1 -p ... -e ... (full options). Earlier versions had problemswith this (but I think it only affected V7)
Make sure it's run with Informix...
On Thu, Apr 21, 2011 at 4:38 PM, Dc Dirk Moolman <DIRK@za.ibm.com> wrote:
> Hi, I'm in a bit of a rush (last minute urgent request from management).
>
> We are running:
> IBM Informix Dynamic Server Version 10.00.FC8XF
> on AIX 5
>
> We have auditing enabled on Production, and this gets restored to a DR
> server (where auditing is not enabled). I am trying to enable it, but get
> the error:
>
> /audit/auditing # onaudit -l 1
> Onaudit -- Audit Subsystem Configuration Utility
> Copyright IBM Corporation 1996, 2004 All rights reserved.
>
> Cannot set audit configuration parameters.
> Problem may be caused by lack of permission, bad
> parameter values, or bad parameter combinations.
>
> I haven't worked with onaudit before - any quick tips ? I compared the
> file permissions between the production and the DR server, and they are
> the same. So I am assuming this is something else ?
>
> Management didn't give me enough time to RTFM, my apologies.
>
> Dirk
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...
--001636eedfcccb5dcb04a1720ccd
have you tried setting config file in
/opt/informix/aaodir
drwxrwxr-x 2 informix informix 8192 Jul 28 2010 aaodir
here is what i use
adtcfg.1 (1 is the instance SERVERNUM )
ADTMODE 1 # Auditing mode
ADTPATH /home/informix/audit_files
# Directory where audit trails will be written by OnLine
ADTSIZE 50000 # Maximum size of any single audit trail file
ADTERR 0 # Error handling modes.
You will need to have following in adtcfg file as well
ADTMODE 1 # Auditing mode
ADTPATH /home/informix/audit_files # Directory where audit trails will be
written by On
Line
ADTSIZE 50000 # Maximum size of any single audit trail file
ADTERR 0 # Error handling modes.
You will have to restart instance
what does onaudit -c show ?
as others have said should be informix user