remote db connection
Posted in 2003
Topics: Installation, Setup & Upgrades, Server Administration, Platform-Specific Issues
Hi All,
I'm having a problem connecting to a remote Informix db.
I have two machines, one is linux, one is sgi irix. Both have 9.21UC4
installed on them.
On the linux box I can connect to the tcp protocol without problems. On
the irix box, I've added an identical line for the tcp connection as is
on the linux box. However, when I try connecting via dbaccess, I get the
error: "931: Cannot locate service/tcp service in /etc/services.". But
it's my understanding the /etc/services file only has local services in
it, not remote port entries.
Can anyone enlighten me as to what I'm doing wrong?
Cheers,
Tosh.
Tosh Baird wrote
> Hi All,
>
> I'm having a problem connecting to a remote Informix db.
> I have two machines, one is linux, one is sgi irix. Both have 9.21UC4
> installed on them.
> On the linux box I can connect to the tcp protocol without problems. On
> the irix box, I've added an identical line for the tcp connection as is
> on the linux box. However, when I try connecting via dbaccess, I get the
> error: "931: Cannot locate service/tcp service in /etc/services.". But
> it's my understanding the /etc/services file only has local services in
> it, not remote port entries.
> Can anyone enlighten me as to what I'm doing wrong?
> Cheers,
>
> Tosh.
Each server must have entries in /etc/services, $INFORMIXDIR/etc/sqlhosts and
$ONCONFIG files.
/etc/services is used for external as well as internal port connections.
Colin Bull
c.bull@VideoNetworks.com
Tosh Baird
wrote:
> Hi All,
>
> I'm having a problem connecting to a remote Informix db.
> I have two machines, one is linux, one is sgi irix. Both have 9.21UC4
> installed on them.
> On the linux box I can connect to the tcp protocol without problems. On
> the irix box, I've added an identical line for the tcp connection as is
> on the linux box. However, when I try connecting via dbaccess, I get the
> error: "931: Cannot locate service/tcp service in /etc/services.". But
> it's my understanding the /etc/services file only has local services in
> it, not remote port entries.
No, no! You can to thought of the /etc/services as of function that maps
a symbolic name of a service to the numeric one.
For example if I have in $INFORMIXDIR/etc/sqlhosts the lines
"ol_u130 onsoctcp u130 turbo"
I must to point out what the "turbo" name means, so at /etc/services I
have the line
"turbo 1540/tcp"
> Can anyone enlighten me as to what I'm doing wrong?
> Cheers,
>
> Tosh.
>
>
Hi Tosh
You ned to add the remote machine (servicesnumber) into your locale =
machine
/etc/services file. You also need to add the remote machine =
ip-adresse/name
into your locale machine /etc/hosts file. You also need to add your =
locale
machine name into the /etc/hosts.equiv fil on the remote machine.
Locale machine /etc/services
Servicename remote port/tcp
Turbo 3992/tcp
Locale machine /etc/hosts
Ip-adr. Machine name
133.33.33.3 kvark
Remote machine /etc/hosts.equiv
kvark
Sorry my english, hope you understand anyway.
M.v.h.
Laila Holt Larsen
lhl@djoef.dk
IT-afdelingen
DJ=D8F
33 - 959944
-----Oprindelig meddelelse-----
Fra: Tosh Baird [mailto:Tosh.Baird@peace.com]=20
Sendt: 11. marts 2003 05:46
Til: ids@iiug.org
Emne: remote db connection [637]=20
Hi All,
I'm having a problem connecting to a remote Informix db.
I have two machines, one is linux, one is sgi irix. Both have 9.21UC4
installed on them. On the linux box I can connect to the tcp protocol
without problems. On the irix box, I've added an identical line for the =
tcp
connection as is on the linux box. However, when I try connecting via
dbaccess, I get the
error: "931: Cannot locate service/tcp service in /etc/services.". But =
it's
my understanding the /etc/services file only has local services in it, =
not
remote port entries. Can anyone enlighten me as to what I'm doing =
wrong?
Cheers,
Tosh.
------_=_NextPart_001_01C2E7AD.00E56FB0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2652.35">
<TITLE>SV: remote db connection [637] </TITLE>
</HEAD>
<BODY>
<P><FONT SIZE=3D2>Hi Tosh</FONT>
</P>
<P><FONT SIZE=3D2>You ned to add the remote machine (servicesnumber) =
into your locale machine /etc/services file. You also need to add the =
remote machine ip-adresse/name into your locale machine /etc/hosts =
file. You also need to add your locale machine name into the =
/etc/hosts.equiv fil on the remote machine.</FONT></P>
<P><FONT SIZE=3D2>Locale machine /etc/services</FONT>
<BR><FONT SIZE=3D2>Servicename =
remote port/tcp</FONT>
<BR><FONT SIZE=3D2>Turbo =
=
3992/tcp</FONT>
</P>
<P><FONT SIZE=3D2>Locale machine /etc/hosts</FONT>
<BR><FONT SIZE=3D2>Ip-adr. =
Machine name</FONT>
<BR><FONT SIZE=3D2>133.33.33.3 =
kvark</FONT>
</P>
<P><FONT SIZE=3D2>Remote machine /etc/hosts.equiv</FONT>
<BR><FONT SIZE=3D2>kvark</FONT>
</P>
<P><FONT SIZE=3D2>Sorry my english, hope you understand anyway.</FONT>
</P>
<P><FONT SIZE=3D2>M.v.h.</FONT>
<BR><FONT SIZE=3D2>Laila Holt Larsen</FONT>
<BR><FONT SIZE=3D2>lhl@djoef.dk</FONT>
<BR><FONT SIZE=3D2>IT-afdelingen</FONT>
<BR><FONT SIZE=3D2>DJ=D8F</FONT>
<BR><FONT SIZE=3D2>33 - 959944</FONT>
</P>
<BR>
<P><FONT SIZE=3D2>-----Oprindelig meddelelse-----</FONT>
<BR><FONT SIZE=3D2>Fra: Tosh Baird [<A =
HREF=3D"mailto:Tosh.Baird@peace.com">mailto:Tosh.Baird@peace.com</A>] =
</FONT>
<BR><FONT SIZE=3D2>Sendt: 11. marts 2003 05:46</FONT>
<BR><FONT SIZE=3D2>Til: ids@iiug.org</FONT>
<BR><FONT SIZE=3D2>Emne: remote db connection [637] </FONT>
</P>
<BR>
<P><FONT SIZE=3D2>Hi All,</FONT>
</P>
<P><FONT SIZE=3D2>I'm having a problem connecting to a remote Informix =
db.</FONT>
<BR><FONT SIZE=3D2>I have two machines, one is linux, one is sgi irix. =
Both have 9.21UC4 installed on them. On the linux box I can connect to =
the tcp protocol without problems. On the irix box, I've added an =
identical line for the tcp connection as is on the linux box. However, =
when I try connecting via dbaccess, I get the</FONT></P>
<P><FONT SIZE=3D2>error: "931: Cannot locate service/tcp =
service in /etc/services.". But it's my understanding the =
/etc/services file only has local services in it, not remote port =
entries. Can anyone enlighten me as to what I'm doing wrong? =
Cheers,</FONT></P>
<P><FONT SIZE=3D2>Tosh.</FONT>
</P>
</BODY>
</HTML>
------_=_NextPart_001_01C2E7AD.00E56FB0--
------=_NextPartTM-000-ed52d806-e631-4818-81a1-86ed47eb5b3e--
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"