Re: Horizontal Ellipse (...) Causing Errors in ODBC Connection
Posted in 2011
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
What is your settings for CLIENT_LOCALE and DB_LOCALE on your query tool environment AND your application environment? What versions of the client SDK are you using? I suspect you have a very complex issue on your data, but the solution maybe simple. Also include the error you get when the query tool raises an error. Was your system recently upgraded? Regards. On Fri, Jul 15, 2011 at 11:27 PM, J. Hart <unleashedmaniac@gmail.com> wrote: > We are having an issue with our Informix database and querying > information where there is a Horizontal Ellipse (...) in the data > column. Our user interface doesn't limit which characters a user > inputs and some are copying and pasting data from a MS Word document > which sometimes pastes in the Horizontal Ellipse (...). > > The problem is that when we try to query the data through an ODBC > Connection the query will their error out or lock up the whole ODBC > service on our web server taking the website down. > > Anyone have experiences with this or an idea on how to get around > this? > > We are running informix 11.5 and using an ODBC Connection to query > data from ColdFusion MX7. > > Thanks, > > James > _______________________________________________ > Informix-list mailing list > Informix-list@iiug.org > http://www.iiug.org/mailman/listinfo/informix-list > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently...
On Aug 19, 10:17 am, Fernando Nunes <domusonl...@gmail.com> wrote: > What is your settings for CLIENT_LOCALE and DB_LOCALE on your query tool > environment AND your application environment? > What versions of the client SDK are you using? > > I suspect you have a very complex issue on your data, but the solution maybe > simple. > Also include the error you get when the query tool raises an error. > Was your system recently upgraded? > > Regards. > > > > > > On Fri, Jul 15, 2011 at 11:27 PM, J. Hart <unleashedman...@gmail.com> wrote: > > We are having an issue with our Informix database and querying > > information where there is a Horizontal Ellipse (...) in the data > > column. Our user interface doesn't limit which characters a user > > inputs and some are copying and pasting data from a MS Word document > > which sometimes pastes in the Horizontal Ellipse (...). > > > The problem is that when we try to query the data through an ODBC > > Connection the query will their error out or lock up the whole ODBC > > service on our web server taking the website down. > > > Anyone have experiences with this or an idea on how to get around > > this? > > > We are running informix 11.5 and using an ODBC Connection to query > > data from ColdFusion MX7. > > > Thanks, > > > James > > _______________________________________________ > > Informix-list mailing list > > Informix-l...@iiug.org > >http://www.iiug.org/mailman/listinfo/informix-list > > -- > Fernando Nunes > Portugal > > http://informix-technology.blogspot.com > My email works... but I don't check it frequently...- Hide quoted text - > > - Show quoted text - I'm not sure about the CLIENT_LOCALE on my query tool. I was not able to find it listed anywhere. The DB_LOCALE is "en_US.819". The application environment was: Client Locale = "en_US.CP1252" and Database Locale = "en_US.819", which I guess were the default settings because I didn't change these when setting up the ODBC. My old SDK I was running was "2.90 TC6R1". I just upgraded the SDK to "3.70 TC3DE". and changed both my locale on my ODBC to "en_US.819". This seems to be working fine and any special characters are just getting converted to a space " ", which is fine for me. I wasn't getting a special error, the ODBC Connection/Service just locked up and I would have to force it to restart. We didn't recently upgrade anything that caused this issue. The issue has randomly been happening since we rolled out the application. It wasn't until I did some extensive troubleshooting that I figured out that it was the Horizontal Ellipse (...) causing the problem. I remember seeing in a database forum somewhere that these characters could be Locale specific which caused me to look into that as a solution. Thanks, James