RE: Which RAID to use?
Posted in 2001
Topics: Performance & Tuning, Storage & Space Management, SQL Development & Query Writing, Server Administration
That is not why Raid 5 is bad. Raid 10 can also fail if a second disk fails, depending on what disk in a stripeset. It is less likely than R5. Raid 5 can FAIL without a disk failure, but a sector failure. This can happen due to the parity bit. See Art's notes. This is why it is !@#$% Raid 5 is generally slow on writes, but on big system like EMC with big caches, you might not notice it. Raid 5 is not good for databases. All disks need to be read for a single read/write {Depending on block, stripe size}. Good for file systems {We only use Raid 10}, but Databases you do not necessary want all disks to work for a single select without a join. What you want table test1 and test2 on different mirror/stripe sets {Raid 10} where there is a join in the select. You want to move busy tables to different Raid sets. Raid 5 is slow on rebuilds. At the end of day, yes Raid 10 is more expensive. What I always ask my client, what is your system/data worth ? How long can you afford to be down ? What is cost of downtime per/hour ? Do calculations and most people will find extra cost is about 2 to 5 hours downtime. PS. It is a good idea to get your mirror disks from a different batch. Some people in the group have lost just about all disk in a matter of days. Also try to have a online spare drive. Test your alarms. Most systems there are tools to check condition of array. We have shell scripts that warn us via email, and GSM SMS to our mobile phones on any error/warring. Hope it helps -----Original Message----- From: Frank [mailto:paul.meaden@compaq.com] Sent: Wednesday, 03 January, 2001 5:30 PM To: informix-list@iiug.org Subject: Re: Which RAID to use? If you can afford RADI 0+1, use it. The scenario you describe with RAID 5 is theoretically realistic. A RAID 5 array can tolerate the loss of one disk, but in the (unlikely) event that you lose another disk at the same time, then your RAID 5 filesystem will break. Twaddell, Ronald <Ronald.Twaddell@nexigent.com> wrote in message news:92vacv$agh$1@news.xmission.com... > > Hello! > > We are about to embark on the creation of a fail over database server using > 2 Sun 4500's and an EMC Clarion disk array with 720 GB disk space. We have > been struggling with the all important question of which RAID level to use. > > > I have heard bad stories of RAID 5 failing because 2 disk drives crash with > in hours of each other. Also, the performance of writes with RAID 5 is a > concern. On the up side you are able to take advantage of more disk space. > > RAID 0+1 seems to be the most tested and proven. > > Any suggestions? > > Thanks very much in advance! > > Ronald Twaddell > DBA > Nexigent Inc > ronald.twaddell@nexigent.com > > > > ----------------------------------------------------- > Confidentiality Notice: This e-mail transmission > may contain confidential or legally privileged > information that is intended only for the individual > or entity named in the e-mail address. If you are not > the intended recipient, you are hereby notified that > any disclosure, copying, distribution, or reliance > upon the contents of this e-mail is strictly prohibited. > > If you have received this e-mail transmission in error, > please reply to the sender, so that Nexigent can arrange > for proper delivery, and then please delete the message > from your inbox. Thank you.
Hannes Visagie wrote in message <931k7g$3i7$1@news.xmission.com>... > > >We have shell scripts that warn us via email, and GSM SMS to our mobile >phones on any error/warring. > Oooo! I'd really like to get my hands on your box-to-SMS technology. How is that done? Do I need to beg? Pay some company some money?