HDR scenarios
Posted in 2017
Topics: High Availability & Replication, Migration, Import/Export & Data Conversion, Clustering, Grid & MACH11
Dear Informix Guru's
I have successfully implemented High availability HDR in Windows environment
with auto switch-over using Connection manager with the IIUG members help.
Especially Mr. ART
Now pulling my hair with some sort of scenarios, which i mentioned below,
because of for the first time we are implementing this in our environment.
Scenarios:
1. How to take dbexport backup whit the HDR pair with no down time.
2. How to manually restart the server without changing the HDR pair server
types. EX: Prim/sec
3.How to make old primary server back to Primary again.
4. What is the chance of data loss when fail over happens.
5. How to reestablish the HDR pair again once the fail-over happens without
data loss.
Thanks in advance to everyone.
1. How to take dbexport backup whit the HDR pair with no down time.
This was been discussed before:
http://members.iiug.org/forums/ids/index.cgi/read/21903
In short, I would not use dbexport: use ontape or onbar with PSM which do not
require downtime.
2. How to manually restart the server without changing the HDR pair server
types. EX: Prim/sec
If you have CM in auto-failover mode you either:
a) stop all CMs before restarting.
b) ensure you stop/start in the correct sequence which is to shut down all
secondaries that your policy permits failover before stopping the primary and
then restart the primary first.
3.How to make old primary server back to Primary again.
http://www-01.ibm.com/support/docview.wss?uid=swg21220123
4. What is the chance of data loss when fail over happens.
If you run HDR in near-sync mode a transaction is not committed until it has
been transmitted to the secondary so you could only lose uncommitted
transactions. Alternatively you can go full sync but this means the primary
always waits for the HDR to commit.
https://www.ibm.com/support/knowledgecenter/en/SSGU8G_12.1.0/com.ibm.admin.doc/i
ds_admin_1417.htm
5. How to reestablish the HDR pair again once the fail-over happens without
data loss.
This depends on whether the logical logs have wrapped around or not. It's
easiest to avoid this by calculating how many logs you're likely to need to
survive for whatever time you deem necessary. If logs have wrapped around you
will need to rebuild the HDR from backup, either ifxclone or onbar/ontape, or
apply logical log backups if you have them.
Ben.
Thanks Benjmin, It is more helpful to me to go ahead. Can you please give clarity on the 5th point.