Re: Online 4.0 tbcheck error
Posted in 1994
June Tong writes: -> ->Well, I hope you haven't already re-built your table, because this is really ->a very minor error. This is probably caused by the automatic extent doubling ->that OnLine does when your table reaches a certain number of extents (which ->I can never remember, and also depends on the version of OnLine). -> ->When OnLine doubled your extent size, it forgot to put the new extent size in ->your systables entry, and only changed it in your partition. It only uses the ->value in your partition, so the fact that it's wrong in systables is totally ->irrelevant, except to you and tbcheck. If you REALLY want to, I suppose you ->can update systables as user informix and set it to 16, but personally, I ->would just ignore it. -> ->This is a bug (can't remember the number), and has been fixed in later versions ->of OnLine, but again, it really doesn't matter. Woe! Stop! That's not right! It does matter! If you have over 8 extents, it is true that your next extent sizes will start doubling... but if you have 8 extents, you have other problems. The more extents you have the more your database is fragmented and the worse your performance is likely to be. If you have more than two or three extents, I would figure out what size I needed the first extent to be and rebuild my table. If you have tables that have over 8 extents, it is time for some serious database maintenance. (BTW, the holidays tend to be a good time to do database maintenance since everyone ELSE is on vacation! :-) ) Regards, - Cathy -------------------------------------------------------------------------------- Cathy Kipp e-mail: ckipp@vth1.vth.colostate.edu Phone: (303) 491-1294 Colorado State University Veterinary Teaching Hospital Fax: (303) 491-1205