Assertion failed!!
Posted in 2003
Topics: Error Codes & Troubleshooting, Logging & Checkpoints
Hi All, I have a weird Asserion failed in production, the BD is online again but I would like to know the cause of this problem. 09:26:46 Assert Failed: No Exception Handler 09:26:46 Informix Dynamic Server Version 7.31.FD2X3 09:26:46 Who: Session(54925, sapr3@ap2int, 5214, -1633749176) Thread(164515, sqlexec, 1a9a1fe08, 28) File: mtex.c Line: 450 09:26:46 Results: Exception Caught. Type: MT_EX_OS, Context: mem 09:26:46 Action: Please notify Informix Technical Support. 09:27:29 Logical Log 255145 Complete. 09:27:54 See Also: /tmp/af.868b4fb6 09:27:54 mtex.c, line 450, thread 164515, proc id 15912, No Exception Handler. 09:27:54 PANIC: Attempting to bring system down 09:28:55 Requested shared memory segment size rounded from 309792KB to 310272KB 09:28:55 Dynamically allocated new virtual shared memory segment (size 310272KB) Anyone who can help me Thanks in advance Luis Arturo López Caballero Proyecto ASARE - Modulo Base, BD Mexico D.F. Tel. 01(55)52294400 Ext. 85705
With this information it would be very difficult to provide any kind of help ... it looks like the AF happened due to a SEGV ... so more information would be there in the AF file ... I would suggest calling up Tech Support and asking for help. Thanx much, Rajib Sarkar Advisory Support Engineer (Wells Fargo Bank) IBM Data Management Group Ph : (602)-217-2100 Fax: (602)-217-2100 As long as you derive inner help and comfort from anything, keep it -- Mahatma Gandhi "luis.lopez0.... " To: ids@iiug.org <luis.lopez02@cf cc: e.gob.mx> Subject: Assertion failed!! [133] Sent by: forum.subscriber @iiug.org 01/27/2003 10:01 AM Hi All, I have a weird Asserion failed in production, the BD is online again but I would like to know the cause of this problem. 09:26:46 Assert Failed: No Exception Handler 09:26:46 Informix Dynamic Server Version 7.31.FD2X3 09:26:46 Who: Session(54925, sapr3@ap2int, 5214, -1633749176) Thread(164515, sqlexec, 1a9a1fe08, 28) File: mtex.c Line: 450 09:26:46 Results: Exception Caught. Type: MT_EX_OS, Context: mem 09:26:46 Action: Please notify Informix Technical Support. 09:27:29 Logical Log 255145 Complete. 09:27:54 See Also: /tmp/af.868b4fb6 09:27:54 mtex.c, line 450, thread 164515, proc id 15912, No Exception Handler. 09:27:54 PANIC: Attempting to bring system down 09:28:55 Requested shared memory segment size rounded from 309792KB to 310272KB 09:28:55 Dynamically allocated new virtual shared memory segment (size 310272KB) Anyone who can help me Thanks in advance Luis Arturo López Caballero Proyecto ASARE - Modulo Base, BD Mexico D.F. Tel. 01(55)52294400 Ext. 85705
I have a similar case open with UK Tech Support. Our two faults could be completely unrelated but you never know. Do you run HDR ? Under V7.31FD4 "14:26:32 Assert Failed: No Exception Handler 14:26:32 Informix Dynamic Server Version 7.31.FD4 14:26:32 Who: Session(20268, app35@prdapp3dbs-dum.lastminute.com, -1, -1647722584) Thread(19904, sqlexec, 9896c6a8, 3) File: mtex.c Line: 454 14:26:32 Results: Exception Caught. Type: MT_EX_OS, Context: mem 14:26:32 Action: Please notify Informix Technical Support. 14:26:32 Assert Failed: No Exception Handler 14:26:32 Informix Dynamic Server Version 7.31.FD4 14:26:32 Who: Session(708, patrol@prddbs2-dum, 29262, -1712765936) Thread(350, sqlexec, 9ae92128, 10) File: mtex.c Line: 454 14:26:32 Results: Exception Caught. Type: MT_EX_OS, Context: mem 14:26:32 Action: Please notify Informix Technical Support. 14:26:55 See Also: /temp/informix_dump/af.51a85797 14:26:55 mtex.c, line 454, thread 19904, proc id 28943, No Exception Handler. 14:26:55 PANIC: Attempting to bring system down " We've now upgarded to V9.30FC3 and we have different output in the logs when it fails, we're just figuring out the best way of tracking down what is filling up the temporary dbspace (11GB), we use very little of this then suddenly a process comes out of nowhere and takes the space up. All the info has been sent to tech support. 17:33:51 Maximum server connections 541 17:34:05 WARNING: temporary space tmpdbs4 is full 17:38:57 Checkpoint Completed: duration was 11 seconds. 17:38:57 Checkpoint loguniq 199276, logpos 0x551018 17:38:57 Maximum server connections 541 17:39:41 WARNING: temporary space tmpdbs5 is full 17:42:27 WARNING: temporary space tmpdbs1 is full 17:44:22 Checkpoint Completed: duration was 18 seconds. 17:44:22 Checkpoint loguniq 199277, logpos 0x8eb018 17:44:22 Maximum server connections 541 17:47:50 WARNING: temporary space tmpdbs4 is full 17:47:51 Assert Failed: No Exception Handler 17:47:51 Informix Dynamic Server Version 9.30.FC3 17:47:51 Who: Session(21140, app16@prdapp1dbs-dum.lastminute.com, -1, 224443400) Thread(20318, sqlexec, 2131dab98, 10) File: mtex.c Line: 420 17:47:51 Results: Exception Caught. Type: MT_EX_OS, Context: mem 17:47:51 Action: Please notify Informix Technical Support. 17:47:51 stack trace for pid 4350 written to /temp/informix_dump/af.534670c7 17:47:51 See Also: /temp/informix_dump/af.534670c7 17:48:06 mtex.c, line 420, thread 20318, proc id 4350, No Exception Handler. 17:48:06 Fatal error in ADM VP at mt.c:12008 17:48:06 Unexpected virtual processor termination, pid = 4350, exit = 0x100 17:48:06 PANIC: Attempting to bring system down -----Original Message----- From: luis.lopez0.... [mailto:luis.lopez02@cfe.gob.mx] Sent: 27 January 2003 17:02 To: ids@iiug.org Subject: Assertion failed!! [133] Hi All, I have a weird Asserion failed in production, the BD is online again but I would like to know the cause of this problem. 09:26:46 Assert Failed: No Exception Handler 09:26:46 Informix Dynamic Server Version 7.31.FD2X3 09:26:46 Who: Session(54925, sapr3@ap2int, 5214, -1633749176) Thread(164515, sqlexec, 1a9a1fe08, 28) File: mtex.c Line: 450 09:26:46 Results: Exception Caught. Type: MT_EX_OS, Context: mem 09:26:46 Action: Please notify Informix Technical Support. 09:27:29 Logical Log 255145 Complete. 09:27:54 See Also: /tmp/af.868b4fb6 09:27:54 mtex.c, line 450, thread 164515, proc id 15912, No Exception Handler. 09:27:54 PANIC: Attempting to bring system down 09:28:55 Requested shared memory segment size rounded from 309792KB to 310272KB 09:28:55 Dynamically allocated new virtual shared memory segment (size 310272KB) Anyone who can help me Thanks in advance Luis Arturo López Caballero Proyecto ASARE - Modulo Base, BD Mexico D.F. Tel. 01(55)52294400 Ext. 85705 ________________________________________________________________________ This e-mail has been scanned for all viruses by Star Internet. The service is powered by MessageLabs. For more information on a proactive anti-virus service working around the clock, around the globe, visit: http://www.star.net.uk ________________________________________________________________________ ------------------------------ This e-mail is intended for the named addressee only. It may contain confidential and/or privileged information. If you have received this message in error, please let us know and then delete this message from your system. You should not copy the message, use it for any purpose or disclose its contents to anyone. ________________________________________________________________________ This e-mail has been scanned for all viruses by Star Internet. The service is powered by MessageLabs. For more information on a proactive anti-virus service working around the clock, around the globe, visit: http://www.star.net.uk ________________________________________________________________________