-27001 Read error occurred during connection atte
Posted in 2003
Topics: Server Administration
We
running Informix Dynamic Server 2000 Version 9.21.UC2
on SCO 5.0.5
In sometimes the next error are on my system, we heave in house system,
and the last change was an system uptdate to a hosts, and 4, or 5 users
can work , if another attemp connect from 4gi or dbaccess or another client,
it hangs and after 5 minutes the database send the message
Thank you
finderr -27001
-27001 Read error occurred during connection attempt.
This error can occur on either the client or database server side.
When you encounter this error on the client side, it indicates that a
network I/O error occurred when the client tried to connect to a
database server. Probably the connection attempt timed out because the
database server or the network was very busy, too many clients were
attempting to connect to the database server simultaneously, or the
database server was taken off-line during the connection attempt.
If you are using Informix Dynamic Server 2000, Informix Dynamic Server,
INFORMIX-Universal Server, or INFORMIX-OnLine Dynamic Server, verify that
the database server is still on-line. If you are using INFORMIX-SE, verify
that the sqlexecd daemon for the database server is still running. Use either
or both of the environment variables INFORMIXCONTIME and INFORMIXCONRETRY on
the client side to increase the connection
time and number of retry attempts.
When you encounter this error on the database server side, it is a
warning that a network I/O error is detected while the database server
is accepting a connection request from a client. This error usually
occurs when the database server or the network is very busy or when too
many clients are trying to connect to the database server at once. The
database server might be taking so long to respond to a client that the
client's connection request timed out before the connection is
complete. Or possibly a client terminated its connection attempt before
the connection is completely established.
If this error is seen only occasionally in the server message log, it
is just a warning. No corrective action is required on the server
side.
If this error occurs frequently on a database server that runs on a
host with multiple processors, you might want to tune the database
server by increasing the number of poll threads and/or listener
threads.
Hi,
most probably this is a system configuration or network problem.
SCO systems have been known for having low default values
for the number of open file descriptors (per process) kernel parameter.
So I would check this first (or get it chacked by System Admin).
[ IDS needs a file descriptor for each chunk in the system (onstat -d)
and a few for things like message log file.
Network connections (TCP/IP via sockets or TLI) also needs an
open file descriptor for each connection.
This should give you an estimate as to how the kernel parameter
should be set ... ]
TIA,
Martin
--
Martin Fuerderer
IBM Informix Development Munich
Data Management Solutions
"HUGO ACOSTA" <hacosta@grupocentraldediscos.com.mx>
Sent by: forum.subscriber@iiug.org
15.02.2003 00:42
To: ids@iiug.org
cc:
Subject: -27001 Read error occurred during connection atte [405]
We running Informix Dynamic Server 2000 Version 9.21.UC2
on SCO 5.0.5
In sometimes the next error are on my system, we heave in house system,
and the last change was an system uptdate to a hosts, and 4, or 5 users
can work , if another attemp connect from 4gi or dbaccess or another
client,
it hangs and after 5 minutes the database send the message
Thank you
finderr -27001
-27001 Read error occurred during connection attempt.
This error can occur on either the client or database server side.
When you encounter this error on the client side, it indicates that a
network I/O error occurred when the client tried to connect to a
database server. Probably the connection attempt timed out because the
database server or the network was very busy, too many clients were
attempting to connect to the database server simultaneously, or the
database server was taken off-line during the connection attempt.
If you are using Informix Dynamic Server 2000, Informix Dynamic Server,
INFORMIX-Universal Server, or INFORMIX-OnLine Dynamic Server, verify that
the database server is still on-line. If you are using INFORMIX-SE, verify
that the sqlexecd daemon for the database server is still running. Use
either
or both of the environment variables INFORMIXCONTIME and INFORMIXCONRETRY
on
the client side to increase the connection
time and number of retry attempts.
When you encounter this error on the database server side, it is a
warning that a network I/O error is detected while the database server
is accepting a connection request from a client. This error usually
occurs when the database server or the network is very busy or when too
many clients are trying to connect to the database server at once. The
database server might be taking so long to respond to a client that the
client's connection request timed out before the connection is
complete. Or possibly a client terminated its connection attempt before
the connection is completely established.
If this error is seen only occasionally in the server message log, it
is just a warning. No corrective action is required on the server
side.
If this error occurs frequently on a database server that runs on a
host with multiple processors, you might want to tune the database
server by increasing the number of poll threads and/or listener
threads.
Related threads
- System Or Internal Error InterruptedIOException
- Informix ODBC Error: Read error occured during con
- error 27001