ISSUE regarding IFXCLONE
Posted in 2017
Topics: Storage & Space Management, Logging & Checkpoints
Hello, After running ifxclone for more than 10 hours and being conscient that nothing was happening (just rootdbs and physical log dbspace were noted in the message log saying that physical restore was done, data dbspace had initied the physical restore but not yet done), (the instance was in fast recovery mode). I decided to bring the target instance down, with the hope of running back ifxclone again. When I run it the following message appeared: 08:50:59 The snapshot instantiation cannot run because another snapshot instantiation is currently running. 08:50:59 Physical restore failed for dbspace number 1. 08:50:59 Snapshot instantiation failed, killing myself. 08:50:59 SMX thread is exiting because it received a CLOSE message from a remote server 08:50:59 invoke_alarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 6 "Internal Subsystem failure: 'MT'" "Snapshot instantiation failed, killing myself." "" 6077' 08:50:59 invoke_alarm(): mt_exec failed, status 32256, errno 0 08:50:59 Fatal error in ADM VP at mt.c:14311 08:50:59 Unexpected virtual processor termination: pid = 22754, exit status = 0x1. 08:50:59 invoke_alarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 6 "Internal Subsystem failure: 'MT'" "Unexpected virtual processor termination: pid =22754, exit status = 0x1." "" 6500' It seems as if the source server has not stopped the clone operation. Does anyone knows how to solve this situation. Any help will be very much appreciated, Best regards,
How does this look on primary / snapshot source side?
The 'snapshot instantiation is currently running' should be detected=20
there.
Can you post an 'onstat -g ath', please? If output is large, please do an =
'egrep -i "rss|sds|dr|smx"' on it.
From: "JUAN ROCA" <jluis.roca@hotmail.com>
To: ids@iiug.org
Date: 24.05.2017 09:21
Subject: ISSUE regarding IFXCLONE [39276]
Sent by: ids-bounces@iiug.org
Hello,=20
After running ifxclone for more than 10 hours and being conscient that=20
nothing=20
was happening (just rootdbs and physical log dbspace were noted in the=20
message=20
log saying that physical restore was done, data dbspace had initied the=20
physical restore but not yet done), (the instance was in fast recovery=20
mode).=20
I decided to bring the target instance down, with the hope of running back =
ifxclone again.=20
When I run it the following message appeared:=20
08:50:59 The snapshot instantiation cannot run because another snapshot=20
instantiation is currently running.=20
08:50:59 Physical restore failed for dbspace number 1.=20
08:50:59 Snapshot instantiation failed, killing myself.=20
08:50:59 SMX thread is exiting because it received a CLOSE message from a=20
remote server=20
08:50:59 invoke=5Falarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 =
6=20
"Internal Subsystem failure: 'MT'" "Snapshot instantiation failed, killing =
myself."=20
"" 6077'=20
08:50:59 invoke=5Falarm(): mt=5Fexec failed, status 32256, errno 0=20
08:50:59 Fatal error in ADM VP at mt.c:14311=20
08:50:59 Unexpected virtual processor termination: pid =3D 22754, exit=20
status =3D=20
0x1.=20
08:50:59 invoke=5Falarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 =
6=20
"Internal Subsystem failure: 'MT'" "Unexpected virtual processor=20
termination:=20
pid =3D22754, exit status =3D 0x1." "" 6500'=20
It seems as if the source server has not stopped the clone operation.=20
Does anyone knows how to solve this situation.=20
Any help will be very much appreciated,=20
Best regards,=20
***************************************************************************=
****=20
Forum Note: Use "Reply" to post a response in the discussion forum.=20
Thanks a lot Andreas, The problem has been solved. I stopped the firewall.
The ADM VP on the source server has crashed. That is supposed to shutdown the server to avoid any memory corruption. To resolve both problems I would bounce the instance. Art Art S. Kagel, President and Principal Consultant ASK Database Management www.askdbmgt.com Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Wed, May 24, 2017 at 3:21 AM, JUAN ROCA <jluis.roca@hotmail.com> wrote: > Hello, > After running ifxclone for more than 10 hours and being conscient that > nothing > was happening (just rootdbs and physical log dbspace were noted in the > message > log saying that physical restore was done, data dbspace had initied the > physical restore but not yet done), (the instance was in fast recovery > mode). > I decided to bring the target instance down, with the hope of running back > ifxclone again. > > When I run it the following message appeared: > > 08:50:59 The snapshot instantiation cannot run because another snapshot > instantiation is currently running. > > 08:50:59 Physical restore failed for dbspace number 1. > 08:50:59 Snapshot instantiation failed, killing myself. > 08:50:59 SMX thread is exiting because it received a CLOSE message from a > remote server > 08:50:59 invoke_alarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 6 > "Internal Subsystem failure: 'MT'" "Snapshot instantiation failed, killing > myself." > "" 6077' > 08:50:59 invoke_alarm(): mt_exec failed, status 32256, errno 0 > 08:50:59 Fatal error in ADM VP at mt.c:14311 > 08:50:59 Unexpected virtual processor termination: pid = 22754, exit > status = > 0x1. > 08:50:59 invoke_alarm(): /bin/sh -c '/opt/informix/etc/alarmprogram.sh 5 6 > "Internal Subsystem failure: 'MT'" "Unexpected virtual processor > termination: > pid =22754, exit status = 0x1." "" 6500' > > It seems as if the source server has not stopped the clone operation. > > Does anyone knows how to solve this situation. > > Any help will be very much appreciated, > > Best regards, > > > ************************************************************ > ******************* > Forum Note: Use "Reply" to post a response in the discussion forum. > >
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g