Onbar level 0 backup failure
Posted in 2005
Topics: Backup & Restore, Storage & Space Management
We have had an Onbar level 0 off-line backup fail with the following error messages: 2005-02-11 20:08:18 3402 3400 ERROR: Unable to get backup data from the database server: buc_fe.c : Archive API processing failed at line 298 for msgtype. 2005-02-11 20:08:19 3402 3400 SQL -25587 Network receive failed. 2005-02-11 20:08:31 3402 3400 ERROR: Unable to start the DB/BLOBspace backup: Archive API error: already open. 2005-02-11 20:13:07 3402 3400 /informix/PRD/bin/onbar_d: process exit 131 (0x83) Can anybody tell me what they mean? Regards David Eves
Hi,
how did you get the impression that you could do an
ON-Bar backup while the server is off-line ?
This has never worked and is not intended to work in
the future.
(And it also does not work with ontape.)
What you can do while the server is off-line is to simply
backup everything by OS/OS utility means (e.g. tar, cpio, dd).
Restore of any of these then is to restore the stuff to its
exact original location and start the server. There will be
no logical log restore possible, because obviously the
server has no (chance to have an) idea that a "backup"
happened while it was off-line.
I hope this makes sense to you.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
forum.subscriber@iiug.org wrote on 11.02.2005 12:01:24:
>
> We have had an Onbar level 0 off-line backup fail with the following
> error messages:
>
> 2005-02-11 20:08:18 3402 3400 ERROR: Unable to get backup data from the
> database server: buc_fe.c : Archive API processing failed at line 298
> for msgtype.
> 2005-02-11 20:08:19 3402 3400 SQL -25587 Network receive failed.
> 2005-02-11 20:08:31 3402 3400 ERROR: Unable to start the DB/BLOBspace
> backup: Archive API error: already open.
> 2005-02-11 20:13:07 3402 3400 /informix/PRD/bin/onbar_d: process exit
> 131 (0x83)
>
> Can anybody tell me what they mean?
>
> Regards
> David Eves
Not
sure that this is the problem, server off-line!!
I think that what David means is that level 0 is equivalent as an offline
backup (sequential))
David, which one is true? Was you server up or down while performing the
Level 0 backup?
-----Original Message-----
From: Martin Fuer.... [mailto:MARTINFU@de.ibm.com]
Sent: Friday, February 11, 2005 10:10 AM
To: ids@iiug.org
Subject: Re: Onbar level 0 backup failure [4248]
Hi,
how did you get the impression that you could do an ON-Bar backup while the
server is off-line ?
This has never worked and is not intended to work in the future.
(And it also does not work with ontape.)
What you can do while the server is off-line is to simply backup everything
by OS/OS utility means (e.g. tar, cpio, dd).
Restore of any of these then is to restore the stuff to its exact original
location and start the server. There will be no logical log restore
possible, because obviously the server has no (chance to have an) idea that
a "backup"
happened while it was off-line.
I hope this makes sense to you.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany Information Management
forum.subscriber@iiug.org wrote on 11.02.2005 12:01:24:
>
> We have had an Onbar level 0 off-line backup fail with the following
> error messages:
>
> 2005-02-11 20:08:18 3402 3400 ERROR: Unable to get backup data from
> the database server: buc_fe.c : Archive API processing failed at line
> 298 for msgtype.
> 2005-02-11 20:08:19 3402 3400 SQL -25587 Network receive failed.
> 2005-02-11 20:08:31 3402 3400 ERROR: Unable to start the DB/BLOBspace
> backup: Archive API error: already open.
> 2005-02-11 20:13:07 3402 3400 /informix/PRD/bin/onbar_d: process exit
> 131 (0x83)
>
> Can anybody tell me what they mean?
>
> Regards
> David Eves
Usually that error happens when you have not cleaned up the
previous backup's onbar sessions still hanging in the memory.
Do a ps -eaf and then grep for onbar and see if your previous try is still
hanging in the Unix output and then kill it.
Once you have cleared then completely then try your backup again.
Hope this helps.
Ravi.
"Lavoie, Diane" <diane.lavoie@domtar.com> wrote:
Not sure that this is the problem, server off-line!!
I think that what David means is that level 0 is equivalent as an offline
backup (sequential))
David, which one is true? Was you server up or down while performing the
Level 0 backup?
-----Original Message-----
From: Martin Fuer.... [mailto:MARTINFU@de.ibm.com]
Sent: Friday, February 11, 2005 10:10 AM
To: ids@iiug.org
Subject: Re: Onbar level 0 backup failure [4248]
Hi,
how did you get the impression that you could do an ON-Bar backup while the
server is off-line ?
This has never worked and is not intended to work in the future.
(And it also does not work with ontape.)
What you can do while the server is off-line is to simply backup everything
by OS/OS utility means (e.g. tar, cpio, dd).
Restore of any of these then is to restore the stuff to its exact original
location and start the server. There will be no logical log restore
possible, because obviously the server has no (chance to have an) idea that
a "backup"
happened while it was off-line.
I hope this makes sense to you.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany Information Management
forum.subscriber@iiug.org wrote on 11.02.2005 12:01:24:
>
> We have had an Onbar level 0 off-line backup fail with the following
> error messages:
>
> 2005-02-11 20:08:18 3402 3400 ERROR: Unable to get backup data from
> the database server: buc_fe.c : Archive API processing failed at line
> 298 for msgtype.
> 2005-02-11 20:08:19 3402 3400 SQL -25587 Network receive failed.
> 2005-02-11 20:08:31 3402 3400 ERROR: Unable to start the DB/BLOBspace
> backup: Archive API error: already open.
> 2005-02-11 20:13:07 3402 3400 /informix/PRD/bin/onbar_d: process exit
> 131 (0x83)
>
> Can anybody tell me what they mean?
>
> Regards
> David Eves
---------------------------------
Do you Yahoo!?
Yahoo! Mail - Find what you need with new enhanced search. Learn more.