Imported restore with TSM and Informix 10
Posted in 2008
Topics: Backup & Restore, Storage & Space Management, Server Administration
Hi all.
I'm kind of stuck trying to do an imported restore using onbar with TSM. I've
tried all kinds of different methods to trace what is happening, but I just
can't get it going - so now I turn to you! ;o)
I'm running 10.00.TC6X2 on Windows 2003 Standard Edition. I've got the
standard restore working quite alright (even though I cannot restore with /3GB
switch set but that's another story). Now I want to import the backup to
another server.
I will be referring to the backed up server as Node1 and the server to restore
to as Node2.
I am pretty sure I got the access rights correct. From Node2 I can see the
backups from Node1 using dsmc. I can also see successful communication between
onbar and TSM in both the onbar file (with BAR_DEBUG=9) and the TSM trace file.
I also see that the root chunk is retrieved from TSM and that pages are
written to the root chunk file. After that I get the error:
Dynamic Server failed to start in Recovery Mode. Check Event Log for errors.
I've checked the Windows event log, the online log and the onbar log without
any further information regarding this error. I've googled it without any hits.
I've tried to trace all file I/O and registry accesses to look for suspicious
errors and also to see if oninit is started at all, but I see nothing special.
Actually, everything (including all log files) looks just fine and there are
no mentioning of any errors. Looking at the onbar log I would say it looks
like it dies without a message right after restoring the root chunk. The only
real sign of an error (except for the message above) is onbar returning code
96.
Let me finish with some info on my settings on Node2 to be able to do the
imported restore:
* Copied ixbar.0, sm_versions, onconfig file and oncfg file from Node1 to
Node2.
* Manually added registry entry for the Node1 instance name.
* Manually added setnet entry for the Node1 instance name.
* INFORMIXSERVER set to Node1 instance name.
* dsm.opt file is set to the Node2 TSM client identity.
I'd really appreciate any ideas on the problem or how I could proceed in
debugging it further.
thanks for listening.
Ok, I'm back with a shorter question: does anyone have any details on how
onbar is launching oninit on Windows? Because from my fileio and registry
traces I can't see any references to oninit.
It feels like onbar is failing in a very early stage, like its missing an
environment variable or something. I have checked that I can launch oninit
from the same command window as I am using for onbar and it comes up all the
way to the logical recovery (which naturally fails with a loud noise).