Re: Single user limit exceeded problem
Posted in 1995
Richard, The solution to your problem is could be: In a single-user version, there is a hidden file in the $INFORMIXDIR/etc dir called .onuser It's been quite a while since I've worked with the single user version, so my spelling of the filename may be alittle off. When you access the database, the username goes in this file. Then if anyone else tries to access Informix, they get a -753 error. Since a user gets about 5 processes in a single user environment, the original user can continue to connect to the database engine. When the user exits the database a null is put in this file in the first character of the username. Now a new user can log in. If for any reason the first user doesn't exit properly, the .onuser file is not updated correctly and becomes corrupted, causing everyone else to continue to get 753 errors. Even if the original user logs in and then out, the only way I found to fix the problem was to switch to user informix and edit the file. Using vi I deleted the file until it was empty (there was a blank line as well as after the username line in the file). Everything worked fine after this. I know this is a long narrative, but I felt the back- ground was necessary. I hope this helps! Tracy W. Nedd National Weather Service - DBA vball@skipper.ssmc.noaa.gov > I have a single user copy of OnLine 5.05 running on a HP > workstation under HP-UX 9. If I login as user A and run i4gl, > programs, modify, everything is OK. If I log in as any other user > and run i4gl, programs, modify I get the error -753 Access > denied, single user limit exceeded. No other users are active > according to TBMONITOR, apart from the Informix daemons, I have > shut OnLine down and restarted it, I have even rebooted HP-UX but > to no avail. I did not even create the program database under > user A in the first place. > > Any ideas will be gratefully received, > > TIA > > -- > Richard Moon > DCS Information Systems Ltd > Tel ++44 (0) 1908 210 510 > Fax ++44 (0) 1908 211 123 >