What does core mean
Posted in 2011
Topics: General Discussion
I am getting an error could not insert new records. Not enough core? What does this core mean? What is the command to see its information? Can we increase it?
What is the exact message? Is it going into the online message log file? Are you seeing this from the application? I know of no place where we print an error with "not enough core" in the text. My suspicion is that the application is using dynamic memory and has a memory leak. What is the size of the app when you get this message? Is this UNIX/LINUX? Are you using /tmp as our swap file? Is /tmp full? From: "ABHISHEK LODHA" <abhishek_lodha13@yahoo.co.in> To: ids@iiug.org Date: 01/05/2011 03:33 AM Subject: What does core mean [22344] Sent by: ids-bounces@iiug.org I am getting an error could not insert new records. Not enough core? What does this core mean? What is the command to see its information? Can we increase it? ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
I got this same error using IDS 11.50.UC6WE on a small Solaris 10 server when
attempting to use load to insert approx 375000 rows into a table:
Database selected.
271: Could not insert new row into the table. 12: Not enough core
847: Error in load file line 93332.
Error in line 2Near character position 0
Database closed.
The online.log shows (repeated a few times):
14:35:30 Requested shared memory segment size rounded from 9448KB to 10240KB
14:35:30 shmget: [EINVAL][22]: key 5256480c: invalid segment size
14:35:30 Assert Warning: Lock table overflow - user id 500, session id 18
14:35:30 IBM Informix Dynamic Server Version 11.50.UC6WE
14:35:30 Who: Session(18, informix@, 0, 20367078)
Thread(46, dbScheduler, 203385d8, 1)
File: rslock.c Line: 2563
14:35:30 Results: Memory allocation error.
14:35:30 Action: Make more virtual memory available to Dynamic Server
14:35:30 stack trace for pid 9547 written to /opt/IBM/informix/tmp/af.4166aad
14:35:30 See Also: /opt/IBM/informix/tmp/af.4166aad
14:35:30 Lock table overflow - user id 500, session id 18
14:35:31 SCHAPI: [post_alarm_message 15-22] Error -243 Could not position
within a table (informix.ph_task).
14:35:31 SCHAPI: [post_alarm_message 15-22] Error -12 Not enough core
I resolved it by increasing SHMVIRTSIZE and LOCKS in the onconfig, splitting
the unload file in two, and then loading again.
Another solution would be to use the dbload utility to load the file.
Dbload uses far fewer server resources and is actually faster than the
dbaccess LOAD verb.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
IIUG Board of Directors (art@iiug.org)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Advanced DataTools, the IIUG, nor any other
organization with which I am associated either explicitly, implicitly, or by
inference. Neither do those opinions reflect those of other individuals
affiliated with any entity with which I am affiliated nor those of the
entities themselves.
On Tue, Jan 11, 2011 at 10:34 AM, STUART BROOKS <brooksst@uk.ibm.com> wrote:
> I got this same error using IDS 11.50.UC6WE on a small Solaris 10 server
> when
> attempting to use load to insert approx 375000 rows into a table:
>
> Database selected.
>
> 271: Could not insert new row into the table. 12: Not enough core
> 847: Error in load file line 93332.
> Error in line 2> Near character position 0
>
> Database closed.
>
> The online.log shows (repeated a few times):
>
> 14:35:30 Requested shared memory segment size rounded from 9448KB to
> 10240KB
> 14:35:30 shmget: [EINVAL][22]: key 5256480c: invalid segment size
> 14:35:30 Assert Warning: Lock table overflow - user id 500, session id 18
> 14:35:30 IBM Informix Dynamic Server Version 11.50.UC6WE
> 14:35:30 Who: Session(18, informix@, 0, 20367078)
>
> Thread(46, dbScheduler, 203385d8, 1)
>
> File: rslock.c Line: 2563
> 14:35:30 Results: Memory allocation error.
>
> 14:35:30 Action: Make more virtual memory available to Dynamic Server
> 14:35:30 stack trace for pid 9547 written to
> /opt/IBM/informix/tmp/af.4166aad
> 14:35:30 See Also: /opt/IBM/informix/tmp/af.4166aad
> 14:35:30 Lock table overflow - user id 500, session id 18
> 14:35:31 SCHAPI: [post_alarm_message 15-22] Error -243 Could not position
> within a table (informix.ph_task).
> 14:35:31 SCHAPI: [post_alarm_message 15-22] Error -12 Not enough core
>
> I resolved it by increasing SHMVIRTSIZE and LOCKS in the onconfig,
> splitting
> the unload file in two, and then loading again.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5b45fa9870d049993ef9a