RE: Exception MT_EX_OS ??
Posted in 1999
Topics: Installation, Setup & Upgrades, SQL Development & Query Writing, Error Codes & Troubleshooting, Server Administration, Triggers, Constraints & Referential Integrity, Migration, Import/Export & Data Conversion, Versions, Editions & End-of-Life
We had same issue after we upgrade Informix from 723uc3 to 731uc3 in Sun
solaris 2.5.1. We got the similar error when we were doing daily export
which may be related with BUG 113804. And we also get the error everytime
while we were runing some update-select statement. Based on Informix Tech
Support the work around is to set Informix to only use single processor
which is totally unacceptable for us. The 731uc5 suppose to fix the bug. But
it will not be avaiable until January and I don't know if it is going to
introduce some new issue.
Jean Wang
-----Original Message-----
From: Art S. Kagel [mailto:kagel@bloomberg.net]
Sent: Tuesday, December 21, 1999 2:37 PM
To: informix-list@iiug.org
Subject: Re: Exception MT_EX_OS ??
Helmut Leininger wrote:
>
> Hi,
>
> After migration of the IDS Server from 7.23.UC1 to 7.31.UC4 we get an
> Exception MT_EX_OS about twice a day.
>
> Any hint is welcome.
>
> TIA
> Helmut
>
> Error in the logfile:
What are the previous 6 or 8 lines? There may be a hint about what the
engine was doing.
OOOOH! I just noticed this is BUG# 113804 a crash caused by running
dbschema!
See if you can get anyone to verify if someone was using dbschema at the
time of the crashes. The fix to this bug is in IDS 7.31UC5 which was just
released last week. Meanwhile get my myshema.ec utility which does not seem
to trigger the bug the way that dbschema does. Myschema is contained in the
package utils2_ak in the IIUG Software Repository. It has some nice
features beyond what dbschema provides and does everything that dbschema
does except print out data distributions (I'll decode those suckers
someday).
> 09:59:34 Assert Failed: No Exception Handler
> 09:59:34 Informix Dynamic Server Version 7.31.UC4
> 09:59:34 Who: Session(2, informix@, 0, 0)
> Thread(8, soctcppoll, 0, 1)
> File: mtex.c Line: 446
> 09:59:34 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> 09:59:34 Action: Please notify Informix Technical Support.
> 09:59:47 See Also: /tmp/af.3f04176, shmem.3f04176.0
> 09:59:49 mtex.c, line 446, thread 8, proc id 31658, No Exception
> Handler.
> 09:59:49 PANIC: Attempting to bring system down>
> onconfig:
[SNIP]
> SHMBASE 0x30000000 # Shared memory base address
[SNIP]Is this the correct SHMBASE for your platform? Check the release notes it
looks rather odd to me, but you did not post platform info so who knows?
Art S. Kagel
Wang Jean wrote:
> We had same issue after we upgrade Informix from 723uc3 to 731uc3 in Sun
> solaris 2.5.1. We got the similar error when we were doing daily export
> which may be related with BUG 113804. And we also get the error everytime
> while we were runing some update-select statement. Based on Informix Tech
> Support the work around is to set Informix to only use single processor
> which is totally unacceptable for us. The 731uc5 suppose to fix the bug. But
> it will not be avaiable until January and I don't know if it is going to
> introduce some new issue.
>
> Jean Wang
>
> -----Original Message-----
> From: Art S. Kagel [mailto:kagel@bloomberg.net]
> Sent: Tuesday, December 21, 1999 2:37 PM
> To: informix-list@iiug.org
> Subject: Re: Exception MT_EX_OS ??
>
> Helmut Leininger wrote:
> >
> > Hi,
> >
> > After migration of the IDS Server from 7.23.UC1 to 7.31.UC4 we get an
> > Exception MT_EX_OS about twice a day.
> >
> > Any hint is welcome.
> >
> > TIA
> > Helmut
> >
> > Error in the logfile:
>
> What are the previous 6 or 8 lines? There may be a hint about what the
> engine was doing.
>
> OOOOH! I just noticed this is BUG# 113804 a crash caused by running
> dbschema!
> See if you can get anyone to verify if someone was using dbschema at the
> time of the crashes. The fix to this bug is in IDS 7.31UC5 which was just
> released last week. Meanwhile get my myshema.ec utility which does not seem
>
> to trigger the bug the way that dbschema does. Myschema is contained in the
>
> package utils2_ak in the IIUG Software Repository. It has some nice
> features beyond what dbschema provides and does everything that dbschema
> does except print out data distributions (I'll decode those suckers
> someday).
>
> > 09:59:34 Assert Failed: No Exception Handler
> > 09:59:34 Informix Dynamic Server Version 7.31.UC4
> > 09:59:34 Who: Session(2, informix@, 0, 0)
> > Thread(8, soctcppoll, 0, 1)
> > File: mtex.c Line: 446
> > 09:59:34 Results: Exception Caught. Type: MT_EX_OS, Context: mem
> > 09:59:34 Action: Please notify Informix Technical Support.
> > 09:59:47 See Also: /tmp/af.3f04176, shmem.3f04176.0
> > 09:59:49 mtex.c, line 446, thread 8, proc id 31658, No Exception
> > Handler.
> > 09:59:49 PANIC: Attempting to bring system down> >
> > onconfig:
> [SNIP]
> > SHMBASE 0x30000000 # Shared memory base address
> [SNIP]> Is this the correct SHMBASE for your platform? Check the release notes it
> looks rather odd to me, but you did not post platform info so who knows?
>
> Art S. Kagel
Hi,
We specified VP-class NET on NETTYPE soctcp, SINGLE_CPU_VP 0, NUMCPUVP 1 and
relinked the application (written in a third party 4-GL like language, using
Informix libraries). We cannot say yet if the error occurs less often now.
However, the last MT_EX_OS exception referred to kaio instead of soctcppoll.
Regards
Helmut
--
Helmut Leininger
Bull AG / Vienna
Open Systems Support
Email: h.leininger@bull.at
helmut.leininger@bull.net
This opinion is mine and not necessarily that of my employer.
No guarantees whatsoever.