Ontape error : out of virtual shared memory
Posted in 2004
Topics: Backup & Restore
Sorry for my bad english !
Every days at 00h, i save the database with ontape -s -L 0.
The Compaq server is idle.
Some time i have these errors and i must restart the server because informix
is blocked
00:00:57 shmat: [ENOMEM][12]: out of available data space, check system MAXMEM
00:00:57 out of virtual shared memory
********
07:25:45 shmat: [ENOMEM][12]: out of available data space, check system MAXMEM
cl wrote:
> Sorry for my bad english !
Pas de probl'me. (Though Babelfish wasn't very impressed with that
remembered French.)
> Every days at 00h, i save the database with ontape -s -L 0.
> The Compaq server is idle.
>
> Some time i have these errors and i must restart the server because informix
> is blocked
>
> 00:00:57 shmat: [ENOMEM][12]: out of available data space, check system MAXMEM
>
> 00:00:57 out of virtual shared memory>
> ********
>
> 07:25:45 shmat: [ENOMEM][12]: out of available data space, check system MAXMEM
So, have you looked at how your kernel is configured, and how much
shared memory is available, how much swap space is available, and so on?
You've not said which platform you're running on - it might be a PC or
it might be something bigger. You've not said which o/s you're
running except to hint it is Unix.
--
Jonathan Leffler #include <disclaimer.h>
Email: jleffler@earthlink.net, jleffler@us.ibm.com
Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/